WordPress.org

Support

Support » Plugins and Hacks » Page Analysis Keyword Density Not Correct

Page Analysis Keyword Density Not Correct

  • canadianangelxo
    Member

    @canadianangelxo

    In the page analysis it says

    The keyword doesn’t appear in the first paragraph of the copy, make sure the topic is clear immediately.

    The keyword density is 0.52%, which is a bit low, the keyword was found 2 times.

    My focus keyword DOES appear in the first paragraph as well as in my meta description.

    I have included my keyword in my post 6 times and it’s only showing 2?

    Hope this gets fixed soon, was working fine a few days ago before I updated to 3.9, yet this plugin says it’s compatible up to 3.9

    https://wordpress.org/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • This happens to me too, especially when I use text decorations like bold.

    canadianangelxo
    Member

    @canadianangelxo

    Hmm I haven’t had the issue before with text decorations like bold,

    The keyword density issue seems to have fixed itself and now that same post is showing the correct amount of keywords. Weird!

    Sam-adventure-traveller
    Member

    @sam-adventure-traveller

    Just started building a new site and having a similar problem. Page Analysis reports Meta Description does not contain target key phrase. It is the first term in my SEO Meta Description.

    This and other inaccurate reporting is erratic so it’s difficult to isolate a conflict with another plugin. I currently have W3 Total Cache and WordPress HTTPS installed and activated.

    Frustrating.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Page Analysis Keyword Density Not Correct’ is closed to new replies.