Support » Plugin: SiteOrigin CSS » Padding Won’t Work

  • Resolved biljnaishrana

    (@biljnaishrana)


    Hi!

    First of all, thank you for this wonderfully helpful plugin.
    I have made quite some changes with this plugin successfully.

    However, I have had this issue today.

    I want to widen the space between my logo and menu items in my top bar.
    When I increase the padding-right of the logo image in INSPECT,
    it looks just like I want it.

    Then I copy paste the changed element into the Custom CSS editor
    and nothing happens.

    I can send the screen shots.

    Thank you in advance for your help,
    Marina

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi Marina

    Thank for posting.

    When I inspect your logo I can see 120px of right padding from the SO CSS stylesheet. If you check your site using another browser, can you perhaps see the padding?

    biljnaishrana

    (@biljnaishrana)

    Hi Andrew!

    Many thanks for your reply.

    Yap, it is currently 120px and I would like to be 400px.

    So, I add the following in the CustomCSS:

    #img.menu-image.menu-image-title-hide {
    padding-right: 400px;
    }

    But it doesn’t work. What should I do differently? 🙂

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks for the update, I’m with you now 🙂

    When referring to img, that’s all you need, it’s a tag. At the moment you’re referring to img as though it’s an ID name (the hash). Change your selector to img.menu-image.menu-image-title-hide and the rule should take effect.

    biljnaishrana

    (@biljnaishrana)

    Thank you Andrew!

    Well, I have just added:

    #img.menu-image.menu-image-title-hide {
    padding-right: 400px;
    }

    but still no change. 🙁

    Plugin Author Andrew Misplon

    (@misplon)

    That looks like the same as the rule was before. img isn’t an ID so there shouldn’t be a preceding hash. You’re referring to the img tag so your selector should be img.menu-image.menu-image-title-hide.

    https://www.w3schools.com/css/css3_images.asp

    biljnaishrana

    (@biljnaishrana)

    Awwww The #!!! Thank you for your patience with me. It worked like a charm! 🙂

    Plugin Author Andrew Misplon

    (@misplon)

    Glad to hear you’re making progress.

    More here https://stackoverflow.com/questions/602168/in-css-what-is-the-difference-between-and-when-declaring-a-set-of-styles.

    All the best with your site 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Padding Won’t Work’ is closed to new replies.