Support » Fixing WordPress » padding-top hides links on blog page

  • Resolved tonvandervalk66


    The links to posts (H2.entry-title) on this blogpage do not react. Neither do the “read further” (“verder lezen”) links. Except for the post lowest on the page.

    On inspection (F12 in Chrome) it becomes clear the links are hidden by a css style tag attached to the links on H2.entry-title: {
    padding-top: 25em;

    When I toggle the padding-top off, the problem is solved. Normally I can copy the corrected css code to for instance the extra css in customizer. However, because this is the blog page, I do not know where this style tag is defined. I can change the css for any particular element, but not for this one.

    This is the html:
    <span style=”padding-top:25em;” id=”<a-href=""-rel="bookmark">privacy-en-kosten“&gt;Privacy en kosten</span>

    How can I effectively change the css or the html of the blog page here?

    Thanks for taking a look!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Steven Stern (sterndata)


    Forum Moderator & Support Team Volunteer

    I don’t have that in-line CSS on either of my 2017-based blogs. Maybe it’s from some plugin?

    This may be a plugin or theme conflict. Please attempt to disable all plugins. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site. You can then use its admin bar menu to turn on/off plugins and themes one at a time.

    Hi Steven,

    You are right. The problem arises out of the childtheme that I have installed over 2017. When I switch to 2017 there is no problem with the blog links.

    Still: how does this child theme add inline css to the class entry-title? And how can I remove it? I cannot find it in the stylesheet (as it is defined inline in the html-code)

    <span style=”padding-top:25em;” id=”<a-href=""-rel="bookmark">experimenteel-onderzoek-in-het-po“&gt;Experimenteel onderzoek in het PO</span>

    I can try to contact the childtheme builder (Jon Penland) with this question. But if you have any other suggestions, I’d like to hear…


    Moderator Steven Stern (sterndata)


    Forum Moderator & Support Team Volunteer

    The builder of your child theme is the best person to contact. Check the PHP files and look into any jQuery/javascript.

    Actually, using the theme editor in the admin space, I found two java-scripts belonging to the child theme that inserted the inline style element.

    jQuery(document).ready(function(){jQuery("h2.entry-title").each(function(){var panelId=jQuery(this).html().toLowerCase().replace(/\s+/g,"-");jQuery(this).wrapInner(function(){return"<span style='padding-top:25em;' id='"+panelId+"'></span>";})})

    So I removed the style=’padding-top:25em;’; flushed the browser cache; changed the theme to 2017 and back again to the child theme: problem solved!

    Thanks for your advice!

    BTW: this was the child theme by Jon Penland

    Moderator Steven Stern (sterndata)


    Forum Moderator & Support Team Volunteer

    I’ve got my own 2017 child themes 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘padding-top hides links on blog page’ is closed to new replies.