Support » Plugin: WordPress Download Manager » Packages Not being created/Uploaded

  • Resolved mstepek

    (@mstepek)


    Afternoon,

    I have just updated our site to the latest version of WP and WPDM, and all previous file uploads are updating, and allowing downloads.

    The Shared host the site was installed on upgraded their version of PHP meaning we had to update the site to ensure the downloads would still work.

    When trying to add a new file to the site, i am not able to create the package.

    Upon clicking “create package” after providing the file for upload the red wait banner appears and when the green block with white text should come up to tell me the file has been uploaded to the directory, it becomes a small green blob and does not process the file.

    No packages are being created on the new version, i have tried to create packages using the server side tool and this produces the same result.

    http://wordpress.org/extend/plugins/download-manager/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Shaon

    (@codename065)

    it may happen for missing field in db table. Though, those should be auto created, check your db table “ahm_file” if any of following field missing there:
    $sql = “CREATE TABLE IF NOT EXISTS ahm_files (
    id int(11) NOT NULL AUTO_INCREMENT,
    title varchar(255) NOT NULL,
    description text NOT NULL,
    category text NOT NULL,
    file varchar(255) NOT NULL,
    password varchar(40) NOT NULL,
    download_count int(11) NOT NULL,
    access enum(‘guest’,’member’) CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
    show_counter tinyint(1) NOT NULL,
    quota INT NOT NULL,
    link_label varchar(255) NOT NULL,
    icon VARCHAR( 256 ) NOT NULL,
    PRIMARY KEY (id)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8″;

    mstepek

    (@mstepek)

    Thank you for that Shaon,

    The code you gave me would not work as i had the original table in place, however I used an ALTER TABLE statement
    like below

    ALTER TABLE ahm_files ADD icon VARCHAR( 256 ) NOT NULL AFTER link_label

    to add the missing columns in the correct locations to the table.

    That has fixed the issue,

    Thank you

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Packages Not being created/Uploaded’ is closed to new replies.