Support » Plugin: Duplicator - WordPress Migration Plugin » Package creation failed error but log file looks perfect?

  • Resolved wynot


    I received and error when trying to create a package: “This package has encountered errors. Click ‘View Log’ for more details. For additional support see the online knowledgebase”

    I checked the log and everything looks correct – no erors? But I don’t get any packages created?

    I’ve been using this plugin regularly without any problems, so not sure where to look now?

    Any thoughts to help me out?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Ok – this is strange …. I just decided to run it again and this time it worked?!
    I didn’t change anything … just did some googling and reading and then just tried again..hmmm…

    anyway I think I ok now 🙂

    Plugin Author Cory Lamle


    Hey wynot,

    This is because PHP in an interpreted language. So the first time a PHP file is processed it has to interpret the page into byte-code. This first time can be slow. However after that page is cached it will perform much faster. This is also the same with specific IO operations.

    So in short if it timesout the first time, just try again and it will most likely be much faster…

    Thanks for your response – That actually makes sense 🙂
    Thank You!

    Plugin Author Cory Lamle


    No Problem, thanks for the feedback!

    I have been using Duplicator without problem for years to move WP sites online from localhost and as a way of doing local backups.

    Now on a new site I am building locally when I run Duplicator I get the message “This package has encountered errors. Click ‘View Log’ for more details. For additional support see the online knowledgebase”. This has happened repeatedly over several days.

    It completes the scan successfully with “Good” for each item and the log file contains no obvious problems. I have tried deleting all plugins except Duplicator and removing my custom functions.php – same happens.

    Any ideas?

    Plugin Author Cory Lamle


    Hey @wpzippyton,

    If you can give the developer version a try it may have your fixes for the issue your seeing. The very latest version (0.5.3) can be found by following these instructions:

    -> Browse to
    -> Look for the section “Other Versions”
    -> Click on “Development Version” and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues…

    Let me know if this solves your issue…


    Tried that and it’s exactly the same. Very odd – I’ve used duplicator with no problems before and rely on it for efficient site transfers.

    I suspect it’s something to do with my site but quite what eludes me.

    I’ve checked the database, cleaned out some rubbish from it (unused woocommerce tables and some other old stuff), and can see no problems there. I have tried deleting all plugins, custom functions.php, and most recently my child theme directory … still the same.

    Hope you can help – I’d hate to have to do it manually!

    Plugin Author Cory Lamle


    If you want me to look at your system directly you can submit a support ticket…

    I have since found that whenever I work online, Duplicator works with no problem. The problem only occurs when I am working on localhost, so it seems to be to do with my PC. I have reinstalled XAMPP so all my PHP settings are back at default, but the problem persists.

    The error in more detail: What happens is that when Duplicator finishes building the package, if I immediately click on each of the two blue buttons for installer.php and the zip file, I can download them and they work fine. If I don’t click on them at that point but instead click on “All packages” then in the “Package” column I get “View error details…” and a file size of 0B. In the snapshots directory the zip file and installer.php have actually been created and work, so it’s less of a problem than I thought – seems to be just that they are not listed properly at admin.php?page=duplicator rather than a problem with the actual workings of the plugin.

    Plugin Author Cory Lamle


    Did you try the very latest developer line (updated yesterday)?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Package creation failed error but log file looks perfect?’ is closed to new replies.