WordPress.org

Forums

P3 (Plugin Performance Profiler)
[resolved] P3 won't work in Nginx (4 posts)

  1. csfalcao
    Member
    Posted 1 year ago #

    Hi, I1m having the same behavior of this unsolved thread http://wordpress.org/support/topic/p3-and-nginx?replies=8 P3 runs but the pie chart has P3 as 100% loading time.
    I'm using NginX, APC and W3TC caches.

    https://wordpress.org/plugins/p3-profiler/

  2. Kurt Payne
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi csfalcao,

    Are you using ioncube or zend guard?

    Is Nginx configured for caching?

  3. csfalcao
    Member
    Posted 1 year ago #

    Hi Kurt,

    I'm not using those apps, and NginX is configured for caching using W3TC panel (page cache) and DB and object cache with APC. I'm using Cloudflare CDN too.

  4. Kurt Payne
    Member
    Plugin Contributor

    Posted 1 year ago #

    If you look at the advanced stats for the scan, are there only 1-2 visits recorded?

    If so, then cloudflare or your W3TC config may be the problem. Generally speaking, if you see only P3 in the results, then it's because of an incompatible opcode cache or the visits aren't being recorded except for the "stop profiling" call over ajax (which may not invoke other other plugins, so they won't show up).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • P3 (Plugin Performance Profiler)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags