Support » Themes and Templates » P2 V1.3.1 – Can not reply on front-page

  • Resolved waffensam

    (@waffensam)


    click the “Reply” button on front-page when logged in prompts a popup
    ” Whoops! looks like you are not connected to the server. p2 could not connect with WordPress”
    If log out it will turn to the page of the post.

    Help me. Thanks.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Tevya

    (@thefiddler)

    I also have this issue! Happened in a previous version of P2, was fixed, and now back again.

    valuser

    (@valuser)

    Me too. see http://wordpress.org/support/topic/main-changes-in-v-131?replies=5

    some relief in a problem shared

    patung

    (@patung)

    Anyone know where to download the previous version, this current version is borked.

    valuser

    (@valuser)

    patung

    (@patung)

    bosse28

    (@bosse28)

    same problem here! Do you know of any solutions?

    valuser

    (@valuser)

    Have had a go at this. But, caution please, as I barely know what I’m doing.

    In file p2.js in folder js delete lines 840-866 (just below /* On ready */) inclusive.

    Doing this appears (so far) to allow the theme to work almost as expected. Still not fully. Edit – appears to leave front-end and goes to back-end. Reply – goes to Post.

    This on a local install.

    The changes from 1.2.3 to 1.3.1 are at
    http://themes.trac.wordpress.org/changeset?old_path=/p2/1.2.3&new_path=/p2/1.3.1

    Perhaps somebody (who does know what they are doing) will get on to this.

    pasQualle

    (@pasqualle)

    Same issue here 🙁

    Lance Willett

    (@lancewillett)

    Sorry about the troubles — we’re having an issue with the WP.org Extend uploader at the moment, so we can’t get the fixed version updated for you.

    For now you can fix this in your theme by editing header.php:

    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>

    Change to:

    <?php wp_enqueue_script( 'comment-reply' ); ?>

    valuser

    (@valuser)

    Thanks but
    The problem (below) remains after the above has been changed:

    When posting from front page a pop-up appears “Are you sure you want to leave this page.Your comments or posts will be lost if you continue. Click OK to leave this page, or Cancel to stay on this page.” In Firefox ” Are you sure? This page is asking you to confirm that you want to leave – data you have entered may not be saved.”

    followed by “Whoops etc …”

    Also please check behavior after reply is entered and reply button is activated.

    Just FYI – Not vital (for me at least)

    Lance Willett

    (@lancewillett)

    Things are working correctly for me after making that change, I tested it out with WP 3.1 and WP 3.2.

    The missing file is ‘comment-reply.js’ which is added in the wp_enqueue call.

    valuser

    (@valuser)

    Apology.

    All is indeed well in p2 Land on a host server.

    Previous comment referred to a local install – i’ll check this again ??.

    Thanks.

    Tevya

    (@thefiddler)

    The fix worked for me! Thanks Lance.

    valuser

    (@valuser)

    logged out/in on local instal. Fixed.

    frabrunelle

    (@frabrunelle)

    thanks for the fix Lance!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘P2 V1.3.1 – Can not reply on front-page’ is closed to new replies.