WordPress.org

Forums

P2
[resolved] P2 theme has trouble with web browser (5 posts)

  1. Kapeha
    Member
    Posted 10 months ago #

    I need help with my blog with P2 theme. When I add to my p2-blog custom header it will break the menu. The menu moves from in between the banner and the post box to on top of the menu. It seems that removing the Display Text throws off the pagination. Is there anything I can do?

  2. Kathryn
    Automattic Happiness Engineer
    Posted 10 months ago #

    I'd need to see a link to your site in order to have a look directly - could you post it?

    Did you add a header through the Custom Header area of the dashboard, or did you hard-code it in the theme files? If you coded it into the theme files, I recommend trying the dashboard method.

  3. mrjarbenne
    Member
    Posted 9 months ago #

    Related.

    http://wordpress.org/support/topic/theme-p2-adding-custom-header-breaks-menu

    The issue isn't with the header image, as much as it's what happens if you hide the Site Title, which users often do if they have created a custom header image. With the Site Title text removed, the Navigation Menu moves up into it's place. (See the other thread for screenshots)

    I was able to hack out a fix by returning the Site Title back to the page (with the check box in the Header dashboard panel,) then hiding it with CSS.

    .sleeve {
    	visibility: hidden;
    }

    I know this is a ridiculous way to fix it, but I can't seem to figure out how to keep #header .sleeve as a block in the design, without leaving the Site Title activated. Hopefully this will give someone enough info to figure out a more elegant fix.

  4. designsimply
    Member
    Posted 8 months ago #

    @mrjarbenne, thank you for the additional information and link! It was very helpful.

    I can see the problem by completing the following steps:

    1. Install and activate the P2 theme
    2. Go to Appearance > Menus
    3. Create a new menu with a few items
    4. Check the "Primary Menu" box at the bottom
    5. Click the "Save Menu" button
    6. Go to Appearance > Header
    7. Upload and crop a new header image
    8. Check the option for "Show header text with your image"
    9. Click the "Save Changes" button
    10. Check the front page using Firefox

    I checked for the problem in Chrome 35, Safari 7.0.5, and Firefox 30 on a Mac, and I could only see the problem in Firefox and not the other browsers.

    I started writing a report for this issue for our developers, but then I found the problem was already fixed! :) The update will start working in the next P2 theme revision, which should be version 1.5.5, as soon as it comes out.

    If you don't want to wait, you can add the following to the bottom of the theme's style.css file. The next time the theme is updated, it will overwrite your style.css changes and the fix applied in the theme itself will take over (normally you would use a child theme or custom CSS plugin to make edits, but in this case it's okay to edit the theme file directly because it's a temporary workaround that you want to get overwritten in the next theme version anyway).

    #header .sleeve {
        width: 100%;
    }
    #header small {
        text-indent: 0;
        clip: rect(1px, 1px, 1px, 1px);
        position: absolute;
    }
  5. This bug should now be fixed in version 1.5.5 of p2. Thanks again for the reports.

Reply

You must log in to post.

About this Theme

About this Topic