Support » Plugin: Classic Editor » P and BR tags for no reason

  • Resolved chayton

    (@chayton)


    I love the fact that I can go back to the classic editor. I normally just use the html editor because it’s easier for me to see what I’m doing.

    I’ve noticed that I’ve had a bit of an issue now with line breaks and empty p tags appearing where they shouldn’t be. Even if I write in my p tags with no spaces in the html editor like this:

    <p>This is the first paragraph.</p><p>This is the second paragraph.</p><p>Third paragraph.</p>

    When I view it on the front end of the site it’s sticking <br> tags between each paragraph. Is anyone else getting that? Driving me bonkers.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Hmmm, sounds like there is some code somewhere that tweaks how autop works. It never inserts <br> tags before or after <p>. Actually on e of its functions is to remove them. Perhaps “standard” plugins and theme troubleshooting is in order: disable one by one until you get to the culprit…

    Thread Starter chayton

    (@chayton)

    You’re right, it’s actually the theme causing it. I’ll have to dig in to their functions and see what’s going on. Thanks for the response though!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘P and BR tags for no reason’ is closed to new replies.