Support » Fixing WordPress » Oy! Creative Commons plug-in–HELP!!

  • Resolved gen224


    jeez–you’d think that I don’t know what I’m doing around my blog today. :p

    I activated my Creative Commons license last night and found that the options (put it invisibly in the header for the bots) and the option to put the restrictions for distribution (no adding, public/commerical distribution) in the sidebar. Everything’s kosher according to the plugin, right?

    This a.m., the header, Adsense, and sidebar are all GONE! Actually, the sidebar is no longer on the right (it’s at the bottom left) and the header is missing. 😮

    So I realize it’s probably a plugin issue and that’s the only plugin I changed yesterday, and go back to undo it.

    BUT NOW it gives me the following message:
    >>Warning: Invalid argument supplied for foreach() in /home/gen224/public_html/wp-includes/capabilities.php on line 19<<

    WHAT THE HECK? I have no clue what this means, but it is preventing me from accessing any plugin (the entire dashboard is goofed up b/c of this), and I don’t know how to change it to what it’s telling me it should be.

    I guess I really *don’t* know what I’m doing on my blog today! This learning curve is STEEP!!! 😮

    Thanks for whatever help you can offer me. 🙂


Viewing 9 replies - 1 through 9 (of 9 total)
  • Sounds like your database might have gotten corrupted. Check with your host, see what’s up there.

    thanks for the idea–my host (president of the hosting company) said that it’s the php file and not the database. RAts. I don’t know how to edit that (yet)–I’m gonna have to research that.

    Anyone know of any good (free) tutorials on php files?

    Your host needs to stop replying off the cuff and better listen to his users.

    The error you are getting is:
    Warning: Invalid argument supplied for foreach() in /home/gen224/public_html/wp-includes/capabilities.php on line 19

    That particular line is getting data from the database and then going through it, using that foreach() statement. In particular, it’s selecting data from the “user_roles” table of your database. Thus it’s a database problem, because the reason it’s getting that error is that no data is being returned from the database.

    It’s not a PHP issue. The code is good. The input data is bad or missing.

    If you have phpadmin, look at your database for the user_roles table. See what’s in there.

    Okay, I’m willing to concede that you may be right. But how the heck do I fix it?

    I don’t have phpadmin–my cPanel has phpmychats, but that’s it. I’ve just checked my public html folder and its subdirectories and there’s nothing there, either. Am I looking in the right place?

    The only way to fix it is to look at the actual content of the database and figure out what the problem is. This is easier said than done, of course. Does your host not offer anything to let you see/edit the contents of your mySQL database?


    Hmm….I’ve got MySQL account maintenance on my cPanel–when I do a check of the database in question, it says everything is “ok” and “check complete.” I also just chose the “repair” option and ended up with similar comments of “ok” and “repair complete.” Obviously this hasn’t solved the problem, as I still have the same error message when I refresh my blog.

    Is there something else I should look for on my cPanel?

    On my host, in cPanel, when I click on MySQL Databases, I get a screen that offers the “Check” and “Repair” options. But when I go down to the absolute bottom of that page, there is an option for phpMyAdmin. Took me forever to find this.

    Perhaps yours is similar?


    yes! I just found it. OMW…this is soooo far beyond my knowledge base! 😮 I just tweaked my database (compared two of them–one is working well, the other is not) and determined that I probably couldn’t break it any more than it was already broken. 😉 My tweaking did it–there were a bunch of hash “\” marks inserted in to a line of user authorities in my database, and I copied the working one and edited the non-working one to look just like the former. It WORKED!!! I don’t know if giving glory to one’s Deity is acceptable here or not, but I’m doin’ it IRL! 🙂 Never had so much relief as that. Now I get to go remove the plugin that caused all of this and just copy the code and paste it on my site. 🙂



    Phew am i glad i read this post!

    I was about to install the plug in myself… when i tried to put my data from the creative commons website “fill in forms” into the wordpress post using the html code box it caused a glitch in the sidebar and messed up the structure of the site. Thankfully i deleted the custom imported code and the site returned to normal. phew, i did think, well perhaps there’s a plugin which would deal with this, but thankfully having read this i will not be installing the plugin until the problem is fixed, … i suppose creative commons need to know that their code causes turmoil for wordpress users?

    What a shame though as it’s a much needed resource.

    Hope all stays well and you had no further problems


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Oy! Creative Commons plug-in–HELP!!’ is closed to new replies.