WordPress.org

Forums

Oxygen
[resolved] Oxygen Links ALL lead to 404 not found (10 posts)

  1. chrisslemke
    Member
    Posted 1 year ago #

    Hi all,

    this might be stupid because it seems like a beginners mistake but I don't get the hang of it.

    I built the site http://pforzheimferienwohnung.de/ which is running OK so far, but the links don't work. They always lead to 404 Not Found.

    Do you see why that is?

    Thanks from Germany

    Chris

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Did you change anything before this started happening?

  3. chrisslemke
    Member
    Posted 1 year ago #

    Hi WPyogi,

    thanks for the reply.

    No I didn't it actually never worked. In Settings-> Permalinks I set it to "Name" and in the pages the link seems to exist. I'm totally puzzled. What else could the explanation be?

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

  5. chrisslemke
    Member
    Posted 1 year ago #

    Thanks,

    I checked the site, I'm not 100% sure I also understood it.
    To sum up: It is possible that my hoster doesn't support the pretty permalinks and now I need to tell the server otherwise. Halfway correct?

    Can I solve this via the .htaccess file?

    Sorry for asking potentially stupid questions...

  6. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Yes, ask them if mod_rewrite is enabled on the server.

  7. chrisslemke
    Member
    Posted 1 year ago #

    Thanks,
    the provider helped me out. They changed the htaccess to:

    php_value memory_limit 256M
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase //
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . ///index.php [L]
    </IfModule>

    even though I have no clue of what that acutally means. Could I have found out about that myself?

    regards

  8. WPyogi
    Forum Moderator
    Posted 1 year ago #

  9. chrisslemke
    Member
    Posted 1 year ago #

    THANK YOU VERY MUCH!!!

  10. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Sure thing - glad you got it fixed up!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic