Oxygen Featured Slider display posts AND pages (7 posts)

  1. cbear12
    Posted 2 years ago #

    Hi all,

    NOTE: I'm really new to WP (example: I just accidentally posted this in the wordpress.com site and got in trouble! oops)so you may want to take this all with a grain of salt. That being said, because I'm new I think I can sympathize with any confusion others might be feeling!

    I have been wondering for a while and perusing the forum for a way to make the oxygen slider link to pages, not just posts.

    There were a few suggestions to change the slider to a different one completely, but being the beginner that I am at WP, I decided there must be an easier route...

    and there is!!

    It is a simple fix that is a bit awkward, but if you like the Oxygen slider, it should work for you.

    1. Go to plugins.
    2. Click "install new" and search "redirect"
    3. Install and activate the "Quick Page/Post Redirect Plugin"
    4. Follow the instructions (in the posts that the slider links to, redirect to your permanent pages so that when you click on the featured slider it will go straight to your page, not your post).

    You'll have to do a bit of playing around with the images and it will be a little clunky because technically you have a blank post, but it should work until Oxygen (if they do--- please do!) makes it possible to link to pages, not just posts in the featured content slider.

    Hope this works for you all

  2. cbear12
    Posted 2 years ago #

  3. cbear12
    Posted 2 years ago #

    Finally, in order to make the slider look a bit better: remove the date under the title of the posts in your slider.

    Follow this advice: http://wordpress.org/support/topic/oxygen-theme-remove-date?replies=2

  4. crislagorio
    Posted 2 years ago #

    I've been looking for this answer forever. thanks!

  5. Albert Miralles
    Posted 2 years ago #

    Hi guys!

    I was interested to use the featured slider for some specific pages (no posts. Just pages). In my case the solution was:

    change this:

    $args = array( 'posts_per_page' => 6, 'meta_key' => '_oxygen_post_location', 'meta_value' => 'featured', 'post__not_in' => get_option( 'sticky_posts' ) );

    for this:

    $args = array(
    	'post_type' => 'page',
    	'post__in' => array( 1, 2, 3, 4, 5 ),
    	'post_status' => 'publish'

    Note: The numbers are the specific page number of the page which you are interested to publish in the slider

    I hope it can help you!


  6. evildrome
    Posted 2 years ago #

    Hi Albert,

    I tried your change to featured-content.php

    Its not working for me but there are any number of reasons why this might be (I'm using Xammp, I'm using a child theme, Not all my pages have featured images yet, the images are > 750px wide).

    I'll fix all these issues but specific to your mod, I read that to make the slider work with posts, when you're on the "edit post" page, you also need to choose the 'Featured' option in the "Location" menu.

    Pages do not have a "Location" menu. Did you override this requirement with your mod or in some other way?



  7. WPyogi
    Forum Moderator
    Posted 2 years ago #

    For help with Oxygen, it would be better to start your own thread here:


Topic Closed

This topic has been closed to new replies.

About this Topic