Support » Plugin: Free Quotation » Own quotes does not show up, only

  • Resolved AlwaysEnthusiast

    (@alwaysenthusiast)


    I installed Free quotes on my site (http://science-network.tv/). The installation was quote simple. I added the widget on my start page with the title “Stop and think!”. I created one group and added a few quotes manually to this group. They show nicely in the admin view. However, I can’t make them show up in the widget on the start page. I tried “Use only Free_Quotation – display by day” and ensured that at least one quote should have the same date as the server. I also tried “Use only Free_Quotation – display random quotes from database” but that does not work. I ensured that I had chosen the correct group in the widget. The only setting that works is “Use Wikiquote always for quotations displaying”. My preferred setting is definitely to show a random quote from my own manually entered quotes. How can I make that work?

    https://wordpress.org/plugins/free-quotation/

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author kris_IV

    (@kris_iv)

    Nice 🙂 It means that we have problem with $OPTIONS[‘option1’] 😉 I will prepare new version of plugin with other options variables (maybe today after work). It should solve all problems but It can need new configuration of plugin in settings option.

    Have a nice day!

    Plugin Author kris_IV

    (@kris_iv)

    Ok – pleas try update to 2.3.0 version. After this operation plugin will restore all settings to default.

    Hi, I updated your plugin and set the setting to random quotes from my manually entered quotes. Nothing came up. The standard quote works and also Wikiquote. I tried to change dates for my manually entered quotes and changed the settings to display quotes by day. This did not work. There is no way I can make my manually entered quotes to appear.

    For your information in case you have a look at my website. The current setting is random quotes. I have changed my standard quote to:
    “Any fool can make things bigger, more complex, and more violent. It takes a touch of genius-and a lot of courage-to move in the opposite direction.” When you see this quote it means that random quotes does not work.

    Any more ideas?

    Plugin Author kris_IV

    (@kris_iv)

    The problem is only with passing options… Paradoxically not all options (for example quotation sign is passed). You can try ran WP_DEBUG (it will show on your webpage all syntax bugs). It can help us to find solution but your page will be look “not so nice”. You can install WP_Debuger plugin or you can do it manually in wp_config.php (on your server) is line like this:
    define( ‘WP_DEBUG’, false );
    You should change it on:
    define( ‘WP_DEBUG’, true );

    After page refresh on main page we should see all errors 😉

    Thanks for replying all the time. I don’t feel comfortable to mess with my site like you suggest. I might try and set up another test site on an unused domain and try it there. However, it is likely that it will take time before I can do that. Sorry that I can’t make Free Quotation work with random quotes. Apart from that FQ seems to be my ideal plugin. 🙂 I might have a look again to see what other plugins are out there.

    Plugin Author kris_IV

    (@kris_iv)

    OK. I wait on information from you 😉

    I updated WordPress from version 3.9.2 to 4.0 and suddenly “Free Quotation” starts to behave perfect. Perhaps you have made an update that I have missed (because my system updates plugins automatically).

    Plugin Author kris_IV

    (@kris_iv)

    Hi!
    In last update (last week) I rebuild database connection from mysql_querry to mysqli_querry . It can be a solution of your previous problem.

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Own quotes does not show up, only’ is closed to new replies.