Support » Plugin: Free Quotation » Own quotes does not show up, only

  • Resolved AlwaysEnthusiast

    (@alwaysenthusiast)


    I installed Free quotes on my site (http://science-network.tv/). The installation was quote simple. I added the widget on my start page with the title “Stop and think!”. I created one group and added a few quotes manually to this group. They show nicely in the admin view. However, I can’t make them show up in the widget on the start page. I tried “Use only Free_Quotation – display by day” and ensured that at least one quote should have the same date as the server. I also tried “Use only Free_Quotation – display random quotes from database” but that does not work. I ensured that I had chosen the correct group in the widget. The only setting that works is “Use Wikiquote always for quotations displaying”. My preferred setting is definitely to show a random quote from my own manually entered quotes. How can I make that work?

    https://wordpress.org/plugins/free-quotation/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author kris_IV

    (@kris_iv)

    Hi! First of all – thanks that you try this plugin! Now we can go to solution 😉

    I saw that generally plugin work – we get the quotations mark from system. It means, that the problem is with database. My first idea – problem with group/date or settings. The easiest way to find solution is to send me 3 print screen : Widget area (with the view of this widget settings), List of quotation in Free Quotation dashboard, and FQ Settings. You can put this 3 print screens on any file host and put hire links or send it to me on e-mail: krzysztof.kubiak[at]outlook.com .

    We will find a solution 😉

    I have attached three images (print screen) as requested in an e-mail. I am looking forward to your comments on these.

    Plugin Author kris_IV

    (@kris_iv)

    Hi!
    Pleas update plugin to new 2.2.3 version and give me feedback. I think that this small change can have influence on quotation display on your webpage. If everything will be ok – please give me a

    Have a nice day 🙂

    Hi!
    Thanks for trying to fix the problem 🙂 Plugin updated to version 2.2.3. The problem remains. The theme is “Mantra”. Since the problem is also seen when I try to show quote by day it seems related to the database of manually entered quotes (just a wild guess from a non-geek). Any suggestions?

    Plugin Author kris_IV

    (@kris_iv)

    Ok – next try 😉

    Do you see any quotation in dashboard widget?
    Pleas try change settings to last display option:
    Use one standard quotation (always active if Free_Quotation doesn’t have quotation for displaying)
    And add any quotation below in Standard quotation and Author input filed.

    It’s sad that we work in absolutely another time zone… 😀

    Pleas also send me a list of plugins and themes that you use in your WordPress. If you want you can send it by email.

    Hi!
    I changed to the last alternative (Use one standard quotation (always active if Free_Quotation doesn’t have quotation for displaying)). I also put in a test quote as “Standard quotation”. This works fine (and worked fine with version 2.2.2 as well. If I chose random quotation and have a standard quotation then the standard quotation will be shown but none of the other manually entered quotes. I suspect the problem is with the Free quotation database of manually entered quotes.

    I use the theme Mantra. I also use the following plugins: Easy Author Image, Flexible Posts Widget, Limit Login Attempts, Official StatCounter Plugin, Post Author, Redirection, WordPress Popular Posts and of course Free Quotation.

    Plugin Author kris_IV

    (@kris_iv)

    Ok – last question from me – when you are logged to your WordPress, in your Dashboard do you see proper quotation (in dashboard widget: “Free Quotation Info”) if you choose random display option?

    I will check how FQ co-work with other your plugins at evening after my work 🙂

    Have a nice day!

    Hi,
    Thanks for replying quickly. What I see was captured in one of the three print screen images I send you in the e-mail previously. That print screen was taken when FQ was set to random quotations. Was this the information you requested or have I misunderstod?

    Plugin Author kris_IV

    (@kris_iv)

    Yes 🙂 I need one more information from you. When you are logged on page: you see something like this:
    http://en-blog.files.wordpress.com/2013/06/new-wordpress-dashboard.png

    On this page you see a lot of widgets. Between them is one Free Quotation widget – “Free Quotation Info”. If you have option “random” do you see any data in this Free Quotation widget in Dashboard area?

    I have send you two more screen pictures. One with a standard quote (that shows nicely) and one without a standard quote (none of the manually entered quotes show up).

    Plugin Author kris_IV

    (@kris_iv)

    Thanks 🙂

    It’s really confusing but I will check it in home. Generally – the plugin have good connection with database – it calculate how many quotation you have, and display quotation in table, but have problem with data in variables…

    Plugin Author kris_IV

    (@kris_iv)

    First of all – you are use “Post Author” plugin <- this plugin have few error message in WP Debug.

    Second – do you know a little bit of PHP? If yes (or you want try 🙂 ) pleas edit this file:
    Free_Quotation_widget.php

    and add in last but one line (just before ?> ) this lines of code:

    echo '!'.$options['option1'].'!<br>';
    echo '!'.$fq_group_test.'!<br>';
    echo '!'.$table_name.'!<br>';

    You can edit it by Notepad++ (download by FTP client) or simple – you can edit this file in WordPress editor: Dashboard > Plugins > Editor > Select Free Quotation (right upper corner) > Free_Quotation_widget.php (be careful – not Free_Quotation_admin_widget.php!!!).

    After this operation we will see on your main page (if you chose random quotation) 3 important information 🙂 I think, that all problems are connected with lack of this information. This can help us find solution 😉

    You can tray also disable all other plugins and look on main page. Sometimes two plugins make trouble between them. I wait on info from you! 😉

    First I added your code to the widgets file and updated the file. I did the editing directly in WordPress. The outcome of the main page was nothing. The column with widget output became totally empty / blank and none of the other widgets on the front page could deliver any output either (the whole column went white blank). I then omitted the added code and all went back to as before (showing the standard quotation).

    I then deactivated all plugins one at the time testing random quotes between every deactivation. I did not deactivate the Official StatCounter Plugin because I was afraid it would temper with my statistics. Deactivating all other plugins did not make Free Quotation to start deliver any of my manually entered quotations. I had FQ set to display random quotes but it only delivers the standard quotation.

    Any more ideas?

    Plugin Author kris_IV

    (@kris_iv)

    OK – it’s normal that plugin show you standard quotation if you doesn’t have any quotation which accept all criteria. It means that generally it works. I think, that the problem is with $options[‘option1’] . When I create my plugin first time I make one mistake – I use standard option to save settings. And it can be situation, that other plugin use the same option like FQ and for example put to this option different value. I will change it today and if everything will work I update plugin in repository.

    If you have time to make more try, you can try put this code to Free_Quotation_widget.php :

    echo '!'.$fq_group_test.'!<br>';
    echo '!'.$table_name.'!<br>';

    After you add this code it should be look like:

    echo '!'.$fq_group_test.'!<br>';
    echo '!'.$table_name.'!<br>';
    ?>

    if it have any output you can try put this code:
    print_r($options['option1']);
    just after before added.

    If first added code will work correctly – it should be OK. If note you can try add this code just before first if(xxxxx in the same file (doesn`t remove last last 3 lines):
    $options['option1']='7';

    All time – output should be appear on your main page with this widget just after “” sign.

    Sorry but it’s first situation with this problem and I do it blindly if I see only output code… But I declare that if you want i really want help

    After adding your two lines I got the following output:
    “This is a test of a standard quotation”
    Krzysztof Kubiak
    !Science!
    !wp_free_quotation_kris_IV!

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Own quotes does not show up, only’ is closed to new replies.