Support » Plugin: Radio Station » Overriding schedule breaks tabbed view

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter astevens93

    (@astevens93)

    To add to this, it also adds this same error to other ‘days’ in random times.
    However, once the database clears itself of the overriden schedule, it all returns back to normal.

    It seems there are 2 potential fixes here;

    1. the time it takes to update the schedule database in the front end, vs the back end. I’ve noticed this can be some time, this is on ‘shows’ and on ‘schedule overrides’ editing.

    2. Overriding schedule seems to cause issues with the tabbed schedule view

    • This reply was modified 8 months, 1 week ago by astevens93.
    Plugin Author Tony Zeoli

    (@tonyzeoli)

    First, just curious as to what version of WordPress you are running and what version of PHP?

    Thread Starter astevens93

    (@astevens93)

    PHP version is 7.3
    Wordpress version is 5.4.1 though aware that there is a 5.4.2 upgrade available.

    Edit: Actually on 5.4.2. Softaculous was telling me a different v number than WordPress Admin.

    Thanks,

    • This reply was modified 8 months, 1 week ago by astevens93.
    Plugin Author Tony Zeoli

    (@tonyzeoli)

    Okay, we’ll take a look shortly. Stay tuned.

    Plugin Contributor majick

    (@majick)

    @astevens93 Can you install the latest development version and see if the problem persists? We have made a few fixes already and one of them was regarding the override calculations, so if you can confirm whether it persists or not after these changes so we know whether we need to investigate further:
    https://netmix.com/radio-station/docs/FAQ/#how-do-i-install-the-latest-development-version-for-testing

    Thread Starter astevens93

    (@astevens93)

    Hi @majick

    Ok noted, have downloaded and activated and will give it a try. I made the changes 30 minutes ago but still not been published onto the front end yet.

    A few issues I have already noted though.

    Override Date – Set correctly on the creation page. But then when you go back to the Schedule Override page to view all of your overrides, the date shows as a day earlier. For example I set something for the 26th and it shows the 25th.

    It is also blank under ‘Affected Show(s) on Date’ – I wondered if this should show the affected shows, there are definitely shows it is over-riding.

    Will see what happens once it reflects on the front end.

    Another issue I did face when creating a Schedule Override was that I was faced with a blank screen upon publish.

    Directing me to:
    mydomain.com/wp-admin/post.php (but white screen)

    I had to refresh to get back to the WP Admin.

    Will edit post once front end updates.

    Thread Starter astevens93

    (@astevens93)

    Update: 1.5 hours on and the front end schedule has still not been updated from the schedule over-ride, which makes me wonder if I have a problem elsewhere.

    This is the latest branch on GitHub 2.3.1.5

    Plugin Contributor majick

    (@majick)

    @astevens93 Is it possible to provide an URL for us to look at? There certainly seems to be something breaking in the DOM and have not seen this before. So I’d probably need to inspect the HTML to try to track down where the breakage is happening, or if it is simply a styling conflict.

    Plugin Contributor majick

    (@majick)

    @astevens93 The schedule is cleared each time your save a Show or Override. If you are concerned that transient caching may be causing this to not update (that seems unlikely) then there is a “Clear Transients” option in the plugin Settings to not use those while trying to track down the issue.

    Delays in saving times are probably not due to Radio Station, there is not much it is doing at these times except saving some meta data and that should be fairly instant.

    Plugin Contributor majick

    (@majick)

    @astevens93 Oh and the date override column, yeah seems I was overzealous in applying timezone changes to that view in the latest development version, so hence the wrong date display. I will revert those changes there. I will take another look at the “Affected Shows” column, it is standalone logic so ignore that for now, the main thing is that the schedule calculation is working correctly and applying the override.

    Thread Starter astevens93

    (@astevens93)

    Hi @majick thanks for the reply.
    I’ve just enabled Clear Transients and still does not show changes. For reference on the below link Sunday 10am – 12noon should show an over-riden scheduled show.

    https://www.hcrfm.co.uk/schedule-new/

    Happy to chat privately and give you Admin access to the site if necessary.

    Thanks again,
    Alex

    Thread Starter astevens93

    (@astevens93)

    Apologies for some of the styling issues, I seemed to have perfected this in the public release, but the Show Info / Show Image CSS styling elements seem to have changed names in the GitHub release – were a few things changed?

    I was over-riding the CSS stylesheet

    Plugin Contributor majick

    (@majick)

    @astevens93 We try to keep element and class names to a minimum, but some minor things were changed so that the Show highlighting box would display properly. Seems like you have adjusted your CSS as it looks fine.

    For the other issues, please test out the latest development version (2.3.1.6) just pushed and let us know if all resolved:
    https://netmix.com/radio-station/docs/FAQ/#how-do-i-install-the-latest-development-version-for-testing

    Thread Starter astevens93

    (@astevens93)

    Thanks @majick . I’ve installed the latest dev version and I’m not getting anything on that page with the shortcode other than the days of the week. I cleared my custom CSS just in case but still same issue.

    Are you seeing the same?

    https://www.hcrfm.co.uk/schedule-new/

    Plugin Contributor majick

    (@majick)

    @astevens93 Erk yeah I left a javascript debug line in the development version there and it broke the tab selection on page load.

    Have replaced that with something more robust anyway (give the active tab the active classes in the HTML *and* recheck the correct current day tab on load to bypass page caching.) In the meanwhile I have done a few more shift conflict tests and that seems to be working better now too.

    Try it again (with dev version 2.3.1.7)

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Overriding schedule breaks tabbed view’ is closed to new replies.