Support » Plugin: Postie » Override :date is being ignored

  • Resolved preeve9534

    (@preeve9534)


    Hi,

    I’m using WordPress 5.2.1, Postie 1.9.35.

    Postie is working for me, except that I can’t seem to get it to respond to the documented :date override in text emails.

    My post emails are plain text and the first line of the email body is a line of the form:

    :date 1 Jan, 2019

    followed by the rest of the body. The :date marker is not parsed, it just appears at the beginning of the generated post. There are no errors in Debug.

    Has anyone else had this problem? Any suggestions for a fix?

    Thank you,

    Paul

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Easy fix:

    date: 1 Jan, 2019

    See http://postieplugin.com/faq/specifying-post-date/

    Thread Starter preeve9534

    (@preeve9534)

    Wayne,

    Thank you for replying … and my apologies for posting a really rubbish enquiry … I’ve spent a few hours on this and may be losing it!. So, for clarity, my email body looks like this:

    
    date:  1 Jun, 2019
    [aside]<div class='pdjr-logtable'>
    <table width='100%'>
      <tr><td>Position at start of day (lat,lon)</td><td colspan='2'>52.9133872,5.7916186</td></tr>
      <tr><td>Position at end of day (lat,lon)</td><td colspan='2'>52.9133872,5.7916186</td></tr>
      <tr><td>Distance travelled (km)</td><td colspan='2'>0.0</td></tr>
      <tr><td colspan='3'></td></tr>
      <tr><td>Engine run time (h:m)</td><td colspan='2'>0:0</td></tr>
      <tr><td>Generator run time (h)</td><td colspan='2'>0:0</td></tr>
      <tr><td colspan='3'></td></tr>
      <tr><td>Domestic battery state (%)</td><td>n/a</td><td>n/a</td></tr>
      <tr><td>Waste water tank (%)</td><td>52</td><td>52</td></tr>
      <tr><td>Fresh water tanks (PS,SB) (%,%)</td><td>64, 67</td><td>64, 67</td></tr>
      <tr><td>Fuel tanks (PS,SB) (%,%)</td><td>44, 48</td><td>44, 48</td></tr>
    </table>
    </div>[/aside]
    

    which I think conforms to your spec.

    The date: (got it right this time!) is being ignored and the whole line appeats as the first line of my derived post.

    P

    Thread Starter preeve9534

    (@preeve9534)

    FIXED:

    The problem I was experiencing is that the Message configuration option “Filter Newlines” was set to “Yes” (the default I think).

    With this option set the date: tag is not detected. Setting “Filter Newlines” to “No” and Postie behaves as described in the documentation.

    @wayne: maybe adding a note to this effect in the documentation of “date:” (and I guess other similar override tags) would be helpful?

    P

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Thanks for the update. I’ll add some notes/comments.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Override :date is being ignored’ is closed to new replies.