Support » Plugin: WP Statistics » Overflow: blank page

Viewing 13 replies - 1 through 13 (of 13 total)
  • Sorry, meant the overview.

    Plugin Contributor Greg Ross

    (@gregross)

    Check the source of the page (usually ctl-U in your browser) and check for any fatal errors near the bottom.

    Also check the Optimization page for what your PHP memory limit is.

    No errors…

    The end of the page is:

    <div id="contextual-help-wrap" class="hidden no-sidebar" tabindex="-1" aria-label="تبويب محتوى المساعدة">
    				<div id="contextual-help-back"></div>
    				<div id="contextual-help-columns">
    					<div class="contextual-help-tabs">
    						<ul>
    												</ul>
    					</div>
    
    					<div class="contextual-help-tabs-wrap">
    											</div>
    				</div>
    			</div>
    				</div>
    		<script type="text/javascript">
    	jQuery(document).ready(function(){
    		postboxes.add_postbox_toggles(pagenow);
    	});
    </script>

    What should come after that, but missing, is:

    <div class="wrap">
    	<!-- Screen icons are no longer used as of WordPress 3.8. -->

    PHP memory limit is 128M

    This is weird.

    The problem fixes when I disable a number of plugins:

    – ajax-thumbnail-rebuild
    – all-in-one-seo-pack
    – breadcrumb-navxt
    – contact-form-7-to-database-extension
    – contact-form-7
    – custom-adminbar-menus

    All of them must be disabled at the same time.

    Plugin Contributor Greg Ross

    (@gregross)

    Could be one of two things:

    – a JavaScript conflict of some kind.
    – a memory issue.

    Do you have any experience using a JavaScript debugger?

    Now that the page has displayed, go in to the optimization page again and see what the “Last Overview page memory usage” value is.

    Memory usage in PHP: 6,880,312 Byte

    Memory usage in PHP
    Last Overview page memory usage: 132,120,576 Byte

    Memory usage in the overview page
    PHP Memory Limit: 128M

    Plugin Contributor Greg Ross

    (@gregross)

    Yep, you’ve hit the PHP memory limit.

    You can try disabling widgets on the overview page and see if one of them is causing a runaway memory issue. Disable each of the widgets one at a time, then go to the overview page, then check the last memory usage value again.

    If one of them suddenly drops the memory usage way down let me know.

    I tried and disabled all of them, and then allowed only different one each time, but still no luck.

    Actually, the Memory usage in PHP has increased from 6,880,312 Byte (the previous value) to 26,774,304 Byte.

    Plugin Contributor Greg Ross

    (@gregross)

    How many rows do you have in your tables (on the optimization page)?

    164 row in wp_statistics_visit
    105,821 row in wp_statistics_visitor
    59,165 row in wp_statistics_pages

    Plugin Contributor Greg Ross

    (@gregross)

    We sometimes see users with over 100K rows in the visitors table have memory issues, you have a few choices:

    – increase your memory limit (doesn’t look like you need much more)
    – purge some of the older data from the database (Statistics->Optimization->Purging->Purge records older than)
    – don’t use the overview page and instead just use the individual pages (I’m assuming they work)

    Plugin Contributor Greg Ross

    (@gregross)

    Closing due to inactivity.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Overflow: blank page’ is closed to new replies.