Support » Plugin: Custom Post Carousels with Owl » Output is hidden

  • Resolved calfree

    (@calfree)


    I am using a custom theme and I can see the output of the plugin in the widget area I created but it is invisible and in web tools greyed out. I can see the title of the shortcodes widget but I cannot see the carousel displaying the posts. Anything else I place in that widget is displayed but not this plugin’s output. In the Web Tools I see this

    owl.carousel.min.css line 6

    .owl-carousel {
    display: none;
    width: 100%;
    z-index: 1;
    }

    So from my knowledge it is like the JS is not changing the display or something?

    Here is a script at the bottom of the container:
    jQuery(document).ready(function($){
    $(‘#carousel-5’).owlCarousel({
    loop:false,
    autoplay : true,
    autoplayTimeout : 2000,
    smartSpeed : 400,
    fluidSpeed : 400,
    autoplaySpeed : 400,
    navSpeed : 400,
    dotsSpeed : 400,
    margin: 10,
    autoplayHoverPause : false,
    nav : false,
    navText : [‘<‘,’>’],
    dots : false,
    center : false,
    responsiveRefreshRate : 200,
    slideBy : 1,
    mergeFit : true,
    mouseDrag : true,
    touchDrag : true,
    responsive:{
    0:{items:1},
    480:{items:1},
    768:{items:2},
    991:{items:3},
    1200:{items:4},
    1500:{items:6},
    }
    });
    });

    • This topic was modified 2 years, 1 month ago by calfree.
    • This topic was modified 2 years, 1 month ago by calfree.
    • This topic was modified 2 years, 1 month ago by calfree.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author thehowarde

    (@thehowarde)

    Can you verify the full path to the owl carousel CSS that you are referring to. If your theme or another plugin is using our carousel it is possible they could be overriding my instance.

    Thread Starter calfree

    (@calfree)

    I am developing the site on my localhost so here it is:

    http://localhost/demosite/wp-content/plugins/dd-post-carousel/public/css/owl.carousel.min.css?ver=5.4.2

    If I uncheck the display box in Web tools then I see both posts

    • This reply was modified 2 years, 1 month ago by calfree.
    Plugin Author thehowarde

    (@thehowarde)

    There could be many factors involved as to why the carousel is not showing. The most common would be a conflict with another plugin or theme. They’re simply is not enough information in your post to solve your problem.

    The carousel is hidden by default and shown with JavaScript that’s how the carousel works. If there are other script errors then it is probable that the carousel will not show. However this is not a problem with the plugin but more likely something causing the plugin to behave this way. I’m currently using this plugin myself on at least 20 sites.

    The only way I could actually troubleshoot this for you would be to see the live instance and offer some advice which since it’s on your local host I cannot.

    If you put the site on the internet somewhere I would be more than happy to take a look.

    Thread Starter calfree

    (@calfree)

    Thank you I think it is the exact plugin I need so I would really like to use it. The site however is far from done and I cannot put it online yet, but will soon and then let you know. Thanks for your great support

    Oh wait I get this console error:
    TypeError: $(…).owlCarousel is not a function

    As if JQuery is not loading but it definitely is

    • This reply was modified 2 years, 1 month ago by calfree.
    Plugin Author thehowarde

    (@thehowarde)

    I am very confident that unless the theme you’re using includes owl carousel already, it should work. Just let me know when I can look at it on a live instance.

    Thread Starter calfree

    (@calfree)

    I get this error in the console

    TypeError: $(…).owlCarousel is not a function

    As if JQuery is not loading but it definitely is

    Plugin Author thehowarde

    (@thehowarde)

    Let me test things with using the carousel in a widget. The script is only set to enqueue when the shortcode is called, so that it doesn’t cause the script to load when it’s not needed.

    Plugin Author thehowarde

    (@thehowarde)

    For whatever it’s worth, I tested in a widget, and as I expected, it does work. If you’re using a free theme, I can try it with your theme, otherwise, there’s nothing I can do for you until I can see a live version of your site.

    Screenshot

    Thread Starter calfree

    (@calfree)

    Ok thank you I got it to work by loading the js file in my theme functions.php file and it works. The problem is and I am sorry to say it, but it’s not really the plug in I thought it was going to be and not really what I am looking for. The type of plugin I was looking for is the https://motopress.com/products/wordpress-slider/ but it does not work properly and I am not buying something that does not work. Thanks for your time and effort though and sorry for not being able to use your plugin.

    • This reply was modified 2 years, 1 month ago by calfree.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Output is hidden’ is closed to new replies.