Support » Plugin: Memphis Documents Library » Outgrowing Memphis Docs

  • Resolved Cameron Barrett

    (@cameronbarrett)


    Hi,

    We absolutely love Memphis Docs. We’ve been using it for year with few issues.

    Unfortunately, I think we have outgrown Memphis Docs. We’re to the point where when we try to add a new file, the script times out (502 error, script killed by server) after 60 seconds. This is on a dedicated, managed server at WP Engine with plenty of resources.

    I do believe we are the largest Memphis Docs user on the Internet. We’re storing over 1000 documents (PDFs, Excel, Word) across about 115 folders/subfolders.

    The mdocs.bak file that is generated upon every upload is nearly 1MB in file size.

    The stats above are for just one large parent site. The child sites also use Memphis Docs but not as heavily and Memphis Docs continues to work in smaller child sites.

    I’ve done everything I can think of to speed up the database. I converted all the large tables to InnoDB and have gotten the MyISAM overhead down to 200KB for a 2GB database.

    What I can’t determine is where (on what action) Memphis Docs is timing out.

    When I add a file, the file actually gets uploaded to the /uploads/mdocs/ directory and post_id’s show up in wp_posts and wp_postmeta for the upload, but the script times out somewhere, no thumbnails are generated, and the mdocs-post does not show up in the List View in either the front-end or the back-end. But, the mdocs-post Post does get created and can be browsed to (if you get the URL from the database).

    I’m hoping I can help you debug this and you can find a workaround or refactor your code so that requests are not timing out.

    I’m happy to give you temporary Admin access and walk you through what we’re experiencing. We could even set up a zoom.us screenshare at your convenience.

    Bottom line is I don’t want to stop using Memphis Docs. I think it’s a beautiful and useful plugin, but I’m afraid we’ve outgrown it and without your help and come code changes, I will be forced to move our entire document library to Google Docs.

    Please email me (cbarrett@nps.k12.nj.us), and let’s figure out how we can debug this together.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author bhaldie

    (@bhaldie)

    I just sent you an email.

    I worked with WP Engine tech support on this issue and one of the things we tried that I think fixed this was to turn off object caching. It’s not clear exactly what resolved the issue.

    I left the issue alone over the weekend and somehow the issue went away, since I can now add documents again.

    I am closing this issue and will open it again should it resurface.

    Thanks for all you hard work on this plugin and the responsive support.

    I don’t have the issue that you are describing.

    I have 1.75gb of files (>1100) across approximately 120 folders.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.