Support » Plugin: Constant Contact Forms » Outdated Guzzle Version

  • Resolved djcampanelli

    (@djcampanelli)


    The plugin Constant Contact Forms has an older Guzzle version than the plugin Simple Sales Tax. They will not work together and they break the site. Can this be updated please?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Constant Contact

    (@constantcontact)

    As is, I believe the plan is going to be staying with this version of Guzzle for the moment. This is because we’re exploring paths forward right now to update the plugin to use version 3 of our Constant Contact API, as opposed to version 2 which the plugin uses now. As part of that, we would be moving away from using Guzzle completely.

    That said, it doesn’t help with your website, here and now.

    Just to be certain, is this the “Simple Sales Tax” plugin you’re referring to? https://wordpress.org/plugins/simple-sales-tax/

    Thread Starter djcampanelli

    (@djcampanelli)

    yes

    Plugin Author Constant Contact

    (@constantcontact)

    Thanks, checking on some things.

    Plugin Author Constant Contact

    (@constantcontact)

    Is the error happening just automatically, or is it only after trying to make a purchase that something is triggered?

    The “older” style embed code that would be generated in your ConstantContact account is still a very valid way to collect contacts, if it comes down to it. I can’t make any promises on timeline for any amending or removal of Guzzle right now, and we’d rather you be successfully collecting contacts rather than fighting code errors.

    programmin

    (@programmin)

    I am also experiencing Guzzle error and it seems this would be happening whenever some other plugin or module in WordPress is also including Guzzle?

    wp-content/plugins/constant-contact-forms/vendor/constantcontact/constantcontact/src/Ctct/Services/ListService.php(31): Ctct\Services\BaseService->createBaseRequest

    gets an exception:
    PHP Fatal error: Uncaught TypeError: Argument 3 passed to GuzzleHttp\Client::request() must be of the type array, string given, called in /(path to other Guzzle Client.php)

    Plugin Author Constant Contact

    (@constantcontact)

    Hi @programmin

    Yes, it’s potentially going to happen whenever 2 plugins or even the theme have different versions of Guzzle available trying to run, and whose version attempts to be loaded. Definitely understandably frustrating.

    Do you by chance know which other plugin has Guzzle included?

    programmin

    (@programmin)

    It is in our system and not publicly accessible.

    Plugin Author Constant Contact

    (@constantcontact)

    Understood, What I was trying to hopefully get was what the plugin was, in case it’s a publicly downloadable one from WordPress.org here to try and do some further deduction an debugging, to see if we could potentially resolve the conflicts in some way.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Outdated Guzzle Version’ is closed to new replies.