Support » Plugin: Postie » Out of memory error

  • Resolved Strictly Software

    (@strictly-software)


    Hi

    Ever since I upgraded to WP 3.9.2 on Saturday posts that are automatically sent from my PC to my website are not appearing.

    I just did a test with debug on and it started processing a post before dying with this error.

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home/mysite/public_html/wp-content/plugins/postie/simple_html_dom.php on line 131

    A “free” command on my server at the time of this error showed I did have spare memory e.g

    total used free shared buffers cached
    Mem: 2109548 1739620 369928 0 6044 764392
    -/+ buffers/cache: 969184 1140364
    Swap: 4194296 690156 3504140

    I have a 2GB RAM VPS Debian box.

    How can I fix this?

    Thanks

    Rob

    https://wordpress.org/plugins/postie/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi

    Also, when I added a memory increase in that class e.g

    function __construct($dom)
    {
    	ini_set('memory_limit','256M');
    
    	$this->dom = $dom;
    	$dom->nodes[] = $this;
    }

    And I run Postie with debug on I get a load of debug which suggests the post had been posted e.g

    ValidatePoster: post email filter admin@mysite.com
    Confirming Access For admin@mysite.com
    1 has ‘post_via_postie’ permissions
    posting as user 1
    Sent from valid SMTP server.
    new post id is 26149
    Message Id is :<20140812091055.0C73641800B@myserver.mail.com>
    filter_PreferedText: begin 0
    filter_PreferedText: end

    but when I take the postid and edit a post and swap it over with it the post just has

    title = tmptitle
    article = tmpPost

    What is going on?

    Everything was working fine up until Saturday and I don’t know if it’s WP’s new version or your new version but I cannot get a post onto my site through your plugin anymore.

    My drafts folder is full of articles with tmptitle / tmpPost in it.

    Any help please?

    Thanks

    Rob

    I have reverted back to an old version of Postie I had been using for ages as it worked all the time and now the posts are going on. The only thing is that the word “Subject” is being left in the title e.g “Subject Some Title Of a Post”

    Which never happened before.

    Weird. I will have to debug AHHH!!

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Hi Yes it has been increased in many of the places it can be but that is not fixing the problem throwing more memory at the situation.

    A new version of the plugin is giving me out of memory errors when I watch my console and can see 1GB of RAM spare yet an old version works fine.

    I would say it’s not a “add memory” issue but a plugin issue.

    Thanks

    Rob

    Plugin Author Wayne Allen

    (@wayneallen-1)

    What version of Postie is working?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Out of memory error’ is closed to new replies.