Support » Plugin: Jetpack by WordPress.com » Out of memory (allocated 12582912) (tried to allocate 4294967268 bytes)

  • Resolved o6asan

    (@o6asan)


    I moved to WordPress4.7 and PHP7.1.0 on the same day. After that, I had PHP Fatal error: Out of memory (allocated xxxxxxx) (tried to allocate 4294967268 bytes) in \wp-content\plugins\jetpack\json-endpoints.php on line 123.

    Only json-endpoints.php gives this error, so I can use ini_set('memory_limit', '4096M');.
    But the problem is I don’t have such size memory areas because of my WordPress on Windows7 x86. Besides, I think 4096M is so big.

    Any idea?
    Thanks in advance.

Viewing 15 replies - 16 through 30 (of 47 total)
  • Hi Jeremy,

    I had Jetpack Version 4.5, so I checked PHP7.1.0 again. After up dating the error on php_error.log has gone. But I have the same error about apache_error.log still now. Besides, I’ve not seen the site stats at WordPress Dashboard yet.

    With PHP7.0.x I have no trouble, this is the same as before. I hear PHP.NET has released 7.1.1 but I cannot see its binary version on the site. If I test it, I’ll report.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the extra details. We’ve added multiple automated tests to start catching errors with PHP 7.1, and the next minor release, 4.5.1, will include multiple fixes to make Jetpack fully compatible with PHP 7.1 Hopefully that will help!

    I tried PHP7.1.1. The result is same.

    Hi Jeremy!

    I had Jetpack 4.6 which says it has PHP 7.1 compatibility.
    I tried PHP7.1.1 with this version. The error has gone.

    Thanks for your group’s hard work. I very appreciate it.

    Jeremy!
    I come here again.

    I made the topic ‘resolved’ once, but back to ‘not resolved’ again.
    I misunderstood and have the issue still now.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I made the topic ‘resolved’ once, but back to ‘not resolved’ again.
    I misunderstood and have the issue still now.

    Does that mean the problem is back? Is it still the same error on your site?

    It is still the same error on my site.

    I was wrong about the directory that I installed 7.1.1.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting. We’ve run tests on PHP 7.1 and didn’t run into the issue, so the problem might be something else.

    At this point, I think we would need to run more tests with you to try to understand what’s happening on your server. Could you contact us via this form and mention this thread?

    Thanks!

    Hi Jeremy,
    I sent a request about this issue via the form.

    Hi, I too am getting a similar error on PHP 7.1.2:
    PHP Fatal error: Out of memory (allocated 6291456) (tried to allocate 4294967268 bytes) in C:\home\site\wwwroot\wp-content\plugins\jetpack\json-endpoints.php on line 123

    Is this already fixed in an upcoming Jetpack or can I help in any way?

    No.

    Now I use PHP7.0.16.
    They say Jetpack 4.6 has PHP 7.1 compatibility, but I don’t think it’s 100%.

    Though one of WordPress.com engineers added my ticket(=3056104-t) to https://github.com/Automattic/jetpack/issues/4346#issuecomment-281750590, there is no new information for the moment.

    The engineer of WordPress.com suggested me a test. But I couldn’t accept it because of my server environment. If you can, we might be able to find something.

    • This reply was modified 2 years, 9 months ago by o6asan.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Jetpack 4.6 is compatible with PHP 7.1, but we noted a few incompatibilities on servers using OPCache. Do you use OPCache on your server? If so, what happens when you turn it off?

    I haven’t seen this happen again over the past few days. I do use OPCache. I’d imagine most people do, so having compatibility issues with that could lead to bigger problems down to road as more people upgrade to 7.1.

    I’ll post again if this starts happening again.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    having compatibility issues with that could lead to bigger problems down to road as more people upgrade to 7.1.

    Yes, this is definitely something we’ll work on fixing!

    > Do you use OPCache on your server?

    Yes, I do.

    ;zend_extension=php_opcache.dll
    opcache.enable=0
    opcache.enable_cli=0

    If I did the above, the error has gone.

    But, I do agree with Eaton about OPCache.

Viewing 15 replies - 16 through 30 (of 47 total)
  • The topic ‘Out of memory (allocated 12582912) (tried to allocate 4294967268 bytes)’ is closed to new replies.