Support » Plugin: Trackserver » Osmand splits tracks

  • Resolved ptrv

    (@ptrv)


    Hi,

    First; I really like this plugin. Helemaal top!
    I have got it working with Osmand. First on a https website; there it starts a new track every minute. On a http site it starts a new track every hour. So when I start tracking from 9:30 to 10:30, there is a track from 9:30 to 9:59 and one from 10:00 to 10:30. I have tried every setting in Osmand and in Trackserver. No change.
    Maybe I am missing something?

    Thanks, Peter

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author tinuzz

    (@tinuzz)

    Hi Peter,

    I cannot explain the difference between your http and https site, but the splitting of tracks is done by Trackserver according to the ‘OsmAnd trackname format’ option.

    OsmAnd does not have a notion of tracks, it only sends locations. Trackserver groups these into tracks, using a trackname format that contains so-called strftime placeholders. The default is ‘OsmAnd %F %H’, where ‘%F’ stands for ‘yyyy-mm-dd’ and ‘%H’ is the hour. So yes, a tracking session from 9:30 to 10:30 would result in two tracks, split at the whole hour. If you remove the ‘%H’, it will continue to use the same track until the next day.

    If you want to produce multiple tracks per day, but not necessarily starting and ending within one hour on the clock, you have the following options:
    – use the ‘%H’ and merge multiple tracks into one (easy)
    – remove the ‘%H’ and split the track at the right point (more work)
    – remove the ‘%H’, but before starting a new track, rename the existing track to something different (not difficult, but requires logging into WordPress backend).

    I hope this helps.

    Best regards,
    Martijn.

    Plugin Author tinuzz

    (@tinuzz)

    Only just now, I read that you wrote “I have tried every setting […] in Trackserver. No change.”. Did you actually change the trackname format option, and not see any difference? So what are your tracks named like then?

    Best regards,
    Martijn.

    Thread Starter ptrv

    (@ptrv)

    Man! I read “Generated track name” so I thought that setting was just for the name of the track… I don’t have to try to know that this is the solution.
    Sorry for not reading closely and thanks a lot!

    The greetings, Peter

    Plugin Author tinuzz

    (@tinuzz)

    Great 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Osmand splits tracks’ is closed to new replies.