WordPress.org

Support

Support » How-To and Troubleshooting » oscommerce problem since upgrade to 2.0.4

oscommerce problem since upgrade to 2.0.4

  • Yesterday I upgraded from WP2.0.3 to 2.0.4

    Up until then, my oscommerce installation at http://servaas.com.au was happily co-existing with the blog at http://servaas.com.au/blog

    Now that I have upgraded, the /blog is live, and the homepage of oscommerce is live, but if I (or customers) click on any product, they get taken to /blog and get a “page not found” message. Interestingly, static pages such as /contact_us.php and /privacy.php work fine.

    I tried deleting the /blog folder on the server (via FTP) and re-loading all the files from my backup of 2.0.3 but when I went to /wp-admin/index.php it said my database was out of date and asked me to upgrade. I did, and now I have 2.0.4 again and I am back where I started.

    Anyone know what is causing this new conflict?

    Failing fixing the problem with 2.0.4, how do I get back to 2.0.3 which was working fine?

    (edited typos)

Viewing 1 replies (of 1 total)
  • I worked it out.

    I had changed the wrong .htaccess file. I had added the following to the oscomemerce .htaccess

    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    I deleted it from the oscomemerce .htaccess and added it to the wordpress .htaccess and all is working agian now 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘oscommerce problem since upgrade to 2.0.4’ is closed to new replies.
Skip to toolbar