Support » Plugin: Super Progressive Web Apps » Orientation and display issues

  • Resolved aakrealtor

    (@aakrealtor)


    My problem is with the general settings, not a specific page. I am using Astra Theme in WordPress 5.5.1 with PHP 7.4.11. I have used your plugin for a while. However, today I changed the images I use with it. Both images are PNG and sized correctly. Until today everything displayed perfectly. As of today the display setting defaults to “browser” no matter what display format I select and save. Additionally, the orientation setting defaults to “follow device orientation” no matter what orientation I select. I have tried to uninstall and reinstall your app to no avail. Can you offer a solution to this issue? Thanks in advance.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter aakrealtor

    (@aakrealtor)

    Additionally, I the mobile device I am using is the iPhone 7.

    HI @aakrealtor

    Can you please share the website URL?

    Thread Starter aakrealtor

    (@aakrealtor)

    Can you please flush the WP Rocket cache? Seems like a cached version (without the registration of SuperPWA files) is delivering at my end.

    Thread Starter aakrealtor

    (@aakrealtor)

    I flush the WP Rocket cache, the Cloudflare cache and the iPhone 7 browser cache in that order and it has no effect on the issue I am experiencing.

    Hi @aakrealtor

    The PWA is working perfectly over the Android device right now. Regarding orientation and display settings, both won’t work over iPhone, as its not even supported by iOS till this moment.

    Thread Starter aakrealtor

    (@aakrealtor)

    Hi Jose,

    Just a quick update. The display
    feature worked perfectly until I
    upgraded to iOS 13.7. That new
    iteration of Apple’s operating
    system stopped treating PWA apps
    as apps and began treating them as
    websites. Whenever I launched my
    app using your plugin, it would
    appear both in my browser and in
    the app container and looked and
    functioned like a website. Then I
    upgraded the iOS to 14.1 today and
    it is clear that Apple recognized
    the problem and partially corrected
    it. When I launch the app now, it is
    no longer simultaneously launched in
    the browser. The home page appears in
    the container created by your plugin
    without an address bar. However, when
    I launch any other page, the address
    bar reappears with one change. In the
    left corner of the address bar a
    “done” button appears. When it is
    clicked the address bar disappears. I
    expect that this is an interim fix.
    However, I have consulted with senior
    support at Apple and they have sent
    this issue to their engineers for
    review. I expect a response this week,
    but suspect they will punt the ball to
    their next upgrade. I can keep you
    posted if you are interested.

    Jose Varghese

    (@josevarghese)

    Thanks a lot for sharing more details @aakrealtor . Actually, I didn’t have an iPhone to test it out, I usually test PWA features over my friends iPhones and as due to the current pandemic I meet those friends very infrequently.

    Hope you will update this thread with more details so that people like me can learn and update how PWA works now on iOS 🙂

    Have a great day and stay safe!

    Thread Starter aakrealtor

    (@aakrealtor)

    I now have a solution and the PWA app is working perfectly on my iPhone in standalone mode once again. It appears IOS support for for PWA technology was not the issue at all. Instead, it was a network settings issue which prevented my iPhone from properly communication with my website. I simply reset the network on my iPhone and the plugin immediately began functioning correctly.

    Jose Varghese

    (@josevarghese)

    Awesome! Good to hear about that @aakrealtor

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.