WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Organize Series 2.3 upgrade messes things up

[Resolved] Organize Series 2.3 upgrade messes things up

  • After upgrading, posts are not being found for series and are listed in the wrong order under posts.

    Tried deactivating all other plugins and activating organize-series alone, then updated permalinks, but it’s still not working.

    In fact, after activating the plugin, the first post is displayed for each series, but after updating permalinks, nothing is found.

    HELP!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Also, the URL for the root of a series no longer works. For example http://domain.com/series/series-name (in my particular configuration) worked in version 2.2.9 but doesn’t in 2.3.

    Hi guys,
    I do want to make sure things get fixed. There is an automatic import routine that might be getting skipped in your update process. Try the following steps:

    1. Deactivate Organize Series.
    2. Reactivate it (the import is triggered with plugin activation)
    3. Clear any caching from any cache plugins you have installed (such as super-cache or w3-total-cache)
    4. Visit the Organize Series Options page (this will regen permalinks – shouldn’t be necessary but just in case…)

    Report back here if it fixes things. If not, then tell me what version of WordPress you are using and what version of Organize Series you are using.

    Sorry for the problems guys. It just goes to show that no matter how much testing I do, sometimes things I just can’t anticipate happen (incidentally, I tested this on three blogs, each on different servers, before releasing)

    I started getting the following error after upgrading to 2.3: Fatal error: Cannot redeclare this_to_int() (previously declared in /home/knowhost/public_html/wp-content/plugins/organize-series/orgSeries-utility.php:198) in /home/knowhost/public_html/wp-content/plugins/organize-series/orgSeries-utility.php on line 198

    This is the message people (multi-author site) are getting after saving or publishing a post where a photo is inserted (which is pretty much all of them). Site is http://knowabit.com . It’s even happening after saving or publishing posts which are not part of a series. I haven’t noticed that series navigation is messed up, though.

    I thought this might help trouble-shoot.

    Darren, not only does it not help, it makes things worse.

    I’ve left my caching off, deactivated and activated and then the series pages showed one post from the series (not always the first one), instead of a bunch of excerpts and posts were listed in an incorrect order (4, 5, 3, 2, 1, 6, 7, 11, 12, 10, 9, 8, 13) when viewing each post.

    After updating the options, series pages show “not found”. Have a look at http://www.ronitbaras.com

    Is there a way to do the import manually? Some SQL query or standalone PHP perhaps?

    I should note that although this error happens, if the author then backs out using the URL bar to get back to the dashboard, the post *does* has updated and saved normally, but not without giving them a heart attack!

    I see that by visiting your site that the import still has not happened. If you notice the series part number isn’t showing. That’s the critical part (and also why the series archive pages aren’t working as it affects the query for those pages). I know I sound like a broken record but are you SURE you completely deactivated Organize Series and then activated it via the WordPress Manage Plugins page? If so, then there is either something broken with that WordPress install OR there is another plugin interfering with the activation hook. The import routine hooked into the WordPress Plugin activation hooks and will fire off when Organize Series is activated on the Plugin Manage page.

    Also, what version of Organize Series did you upgrade from?

    I can try to whip up another release with a button that you can push to manually do the import routine but it probably won’t be done until Wednesday.

    Oh one more thing. You can check your options table for this key -> org_series_version. If the value is 2.3 then the import won’t work with deactivate and reactivation. Try changing the value to 2.2 WHEN the plugin is already deactivated (this will trick the plugin to think it hasn’t upgraded yet).

    MAKE SURE YOU DO A DATABASE BACKUP FIRST… it’s not a good idea to go messing around directly with the database without that backup!!

    Hey Tuscany, thanks for posting in here. What you are describing isn’t related to the issue posted by Gal. However, it is another issue that will need to be addressed. I didn’t test on a multi-author site so it may be something that slipped through. I’ll add it to my bug tracker for testing and if I can narrow down the source I will release a fix asap

    Quick question Tuscany. Are you using any special photo plugins (if so, they may have a this_to_int() function that’s colliding with mine.

    I just found that I also had similar problems, so I followed your advice. While it did fix those problems, upon saving a post I am still getting a blank page with the message:

    Fatal error: Cannot redeclare this_to_int() (previously declared in /home/knowhost/public_html/wp-content/plugins/organize-series/orgSeries-utility.php:198) in /home/knowhost/public_html/wp-content/plugins/organize-series/orgSeries-utility.php on line 198

    The same message as before.

    Thanks for the quick response! I have Insights and WP Super Edit installed, but I wasn’t using either of them when I myself created a post to test it. Neither is a photo editing plugin but allow different modes of uploading.

    And thanks for adding this to your bug fix list! I’m going to post this on our Authors Only forum, so people don’t have panic attacks when their posts vanish mid-edit. I’ve subscribed to this thread so I hope it’s something that can be sorted quickly!

    Thanks again!

    What’s the photo editing plugin’s name?

    I’m not using one. The only two things I have that even affect photos are Insights and WP Super Edit.

    I just deactivated Insights, cleared the cache, and tried saving a post. Still had the problem. Did the same with WP Super Edit and still having the fatal error message.

    Update: I couldn’t reactivate one of the three modules on Super Edit (Theme Classes) because I got a message in the Dashboard stating it triggered a fatal error. However, even with that part disabled, it’s still throwing the error message.

    Darren, you da man! I put 2.2 in the option_value and activated and all looks well. Phew!

    Your help is much appreciated. Sorry for bombarding you from so many directions, but it’s my wife’s blog 😛

    The option_value field had nothing in it, possibly because I’ve deactivated and reactivated so many times, but maybe have some Plan B for when something like this happens.

    Back to blogging 😀

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Organize Series 2.3 upgrade messes things up’ is closed to new replies.