Support » Plugin: Business Worldpay Gateway for Woocommerce » Orders redirecting great but orders still on Pending Payment

  • Resolved mattmoo138

    (@mattmoo138)


    HI, I have the plugin and woldpay working great. MD5 and password response passwords set to 8 characters. Payment Response URL <wpdisplay item=MC_callback> Payment Response enabled yes, Enable the Shopper Response yes, resultY and resultC uploaded….. payment goes through fine, redirects back to my website fine, but order is still sitting on pending payment so the emails are not automatically generated. am i missing something? this i am trying in test mode, not production.
    thank you .

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author mdsilviu

    (@mdsilviu)

    It’s the 1st line in the documentation “For the payment to be registered in your wordpress/woocommerce installation your urls have to be accessible, it won’t work in local installations or on any installation that has a plugin for “under construction” that blocks public access to the website and to routes.”

    Hi, I have this issue and I don’t have an ‘under construction’ plug in. Is there something else I can check to get this working? Worldpay tell me the plugin is not setup for callback so I won’t work,

    Thanks.

    Plugin Author mdsilviu

    (@mdsilviu)

    Check if the password you set on worldpay matches the one in your wordpress installation. Or if your website it’s not live, meaning you have it on localhost it won’t work.

    I have re-copied the password over to make sure it is the same and the website is live but it still didn’t work. I can use paypal to take payments and this returns to the shop and the order is marked as paid – using this plug in returns me to the shop but the order is not showing as paid.

    Plugin Author mdsilviu

    (@mdsilviu)

    Worldpay doesn’t work as paypal so comparing these 2 it’s not an option. Worldpay posts the data as a form to an url of the website if worldpay can’t do that for some reason the order won’t get updated with the data from the worldpay. IF you fallowed all steps from the documentation and you are 100% sure the passwords are the same the only problem that i can think of it’s that you have something on your website that stops worldpay from posting the data to the url.

    I had a similar issue earlier but was resolved when I disabled an under-construction plugin I installed. Thank you mdsilviu. I appreciate your work and would be willing to contribute at anytime. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Orders redirecting great but orders still on Pending Payment’ is closed to new replies.