Support » Plugin: Greenhouse Job Board » orderby not working / hide description sentence in job list

  • For some reason, the shortcode order isn’t working. This is the shortcode I’ve input on my page:

    [greenhouse display=”description|location|department” orderby=”title”]

    But for some reason, the order doesn’t work and the Titles are not in alpha order at all.

    My second question is whether or not it’s possible to remove the description sentence in the list items: “About CityBase: At its best, local government is a unifying force with the power to dramatically improve lives.”, so that the list would only have a job title, and the link to “Read Full Description »”.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author brownbagmarketing

    (@brownbagmarketing)

    Hi @cdepa
    Thank you for using the Greenhouse WordPress plugin.

    So for the first part of your question:
    If you remove the “orderby” shortcode, does it list the jobs in alphabetical order as desired? When I inspect the sort function on your staging page I can see the JSON object containing the jobs (before any sorting) do appear to be arranged alphabetically.

    As for the second part of your question, the sentence you’d like to remove can be removed by going into the Greenhouse plugin’s settings in your WP dashboard and selecting the “Accordion” Type instead of “Cycle” Type under the Job Board Settings section.

    It’s a great plugin!!

    When removing “orderby” shortcode, the jobs do not list in alpha.

    As for part 2 of my question, I’d gladly use the accordion type, but it’s more important we have a unique URL for each job listing (that seems to go away with the accordion type display. Is that line of description that is shown in the Cycle type display just the first line of the entry, or is that line specified elsewhere in the job postings in the admin? I just need to know exactly how that is generated so I can direct the client to creating a unique description for each job.

    Look forward to hearing back from you and thanks for your help!!

    Plugin Author brownbagmarketing

    (@brownbagmarketing)

    Good morning @cdepa,
    The description shown is just an excerpt from the job description. It grabs the first line or two.
    Maybe you could just move that “About City Base section” to the end of your job descriptions?

    Can you confirm that you’ve removed the orderby shortcode from your staging link?
    We’d like to take a look at the results and want to make sure we’re seeing what you see.

    Thanks

    I had removed it … but when it didn’t work I reverted back.

    http://thecitybase.staging.wpengine.com/careers/ has the following shortcode:
    [greenhouse display=”description|location|department”]

    http://thecitybase.staging.wpengine.com/careers-3/ has the following shortcode:
    [greenhouse display=”description|location|department” orderby=”title” ]

    So you can see it both ways.

    Plugin Author brownbagmarketing

    (@brownbagmarketing)

    Hi @cdepa,
    We believe we’ve identified an issue and have a solution in place.
    It may be a day or two before we can get it pushed out, as we need to QA our solution to insure we haven’t introduced any new problems.
    You can either wait for the update or if you have code level access to your WP installation, I can walk you through the two simple changes made.

    I think I can wait a few days, thanks for all of your help!!!

    Plugin Author brownbagmarketing

    (@brownbagmarketing)

    Hi @cdepa,
    Version 2.7.3 has been deployed.

    Hopefully it will fix your issue.
    You shouldn’t have to use a shortcode to order by title as it appears the jobs come from the GreenHouse API already sorted by title.
    We also added an option in the GreenHouse Job Board Settings to not show the job “excerpt” for the listing.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘orderby not working / hide description sentence in job list’ is closed to new replies.