Support » Plugin: Order Splitter for WooCommerce » Order split not working

  • Resolved rajath1724

    (@rajath1724)


    Hi,

    I have set one of my products as “exclusive”, but it does not get split when i place the order.

    Please help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • @rajath1724 please export your settings through Advanced Settings > Import / Export > Export Settings and paste here.

    • This reply was modified 3 weeks, 6 days ago by richiewatson.
    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    @rajath1724 you might be missing “Auto Split” checkbox on settings page in optional sidebar.

    Thread Starter rajath1724

    (@rajath1724)

    Hey Fahad,

    Thank you for your reply. If I set it to “Auto Split” it splits all 3 products into single orders.

    What i need:
    Order 1: Product 1 , Product 2
    Order 2: Product 3 (this is set to exclusive)

    What is happening:
    Order 1: Product 1
    Order 2: Product 2
    Order 3: Product 3

    Thread Starter rajath1724

    (@rajath1724)

    @richiewatson Here is the exported settings:

    YToxMTp7czoyMjoid2Nfb3NfZ2VuZXJhbF9zZXR0aW5ncyI7YTo2OntzOjI2OiJ3Y19vc19kaXNwbGF5X2NoaWxkX251bWJlciI7czo1MToiWW91IHdpbGwgcmVjZWl2ZSBbTlVNQkVSX09GX0NISUxEX09SREVSU10gcGFja2FnZXMuIjtzOjIxOiJ3Y19vc19saW1pdF9hbHBoYWJldHMiO3M6MDoiIjtzOjIzOiJ3Y19vc19hdXRvX2Nsb25lX3N0YXR1cyI7czowOiIiO3M6MzA6IndjX29zX2N1c3RvbWVyX3Blcm1pc3Npb25fdGV4dCI7czoyODoiQ29uZmlybSB0byBzcGxpdCB5b3VyIG9yZGVyPyI7czoxNzoid2Nfb3Nfb3JkZXJfdG90YWwiO3M6MToiMSI7czoxNzoid2Nfb3NfYXV0b19mb3JjZWQiO3M6MToiMSI7fXM6MTQ6IndjX29zX3NldHRpbmdzIjthOjEzOntzOjg6IndjX29zX2llIjtzOjc6ImRlZmF1bHQiO3M6MjI6IndjX29zX3F0eV9zcGxpdF9vcHRpb24iO3M6NzoiZGVmYXVsdCI7czoxMDoiaW9fb3B0aW9ucyI7YTo2OntzOjE1OiJpbl9zdG9ja19zdGF0dXMiO3M6MDoiIjtzOjE2OiJpbl9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoxNjoib3V0X3N0b2NrX3N0YXR1cyI7czowOiIiO3M6MTc6Im91dF9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoyMDoib3V0X3N0b2NrX2F1dG9tYXRpb24iO3M6Mjoibm8iO3M6MTY6Im91dF9zdG9ja19hbW91bnQiO3M6MzoieWVzIjt9czoxNDoid2Nfb3NfcHJvZHVjdHMiO2E6Mzp7czo5OiJleGNsdXNpdmUiO2E6MTp7aTowO3M6MzoiMzY4Ijt9czo3OiJkZWZhdWx0IjthOjE6e2k6MDtzOjE6IjAiO31zOjk6ImluY2x1c2l2ZSI7YTowOnt9fXM6MjA6IndjX29zX2dyb3VwX3N0YXR1c2VzIjthOjA6e31zOjEwOiJ3Y19vc19jYXRzIjthOjE6e3M6MTE6InNwbGl0X3JhdGlvIjtzOjA6IiI7fXM6MTY6IndjX29zX2FkZGl0aW9uYWwiO2E6Mzp7czoxNzoic3BsaXRfc3RhdHVzX2xvY2siO3M6MDoiIjtpOjA7czo3OiJyZW1vdmFsIjtpOjE7czoxOiIwIjt9czoxODoid2Nfb3NfYWxsX3Byb2R1Y3RzIjtzOjA6IiI7czoxMzoid2Nfb3NfdmVuZG9ycyI7YTowOnt9czoxNzoid2Nfb3Nfd29vX3ZlbmRvcnMiO2E6MDp7fXM6MTY6IndjX29zX2F0dHJpYnV0ZXMiO2E6MDp7fXM6MjM6IndjX29zX2F0dHJpYnV0ZXNfdmFsdWVzIjthOjA6e31zOjIyOiJ3Y19vc19hdHRyaWJ1dGVzX2dyb3VwIjthOjA6e319czoxOToid2Nfb3NfY3V6dG9taXphdGlvbiI7YTowOnt9czoxODoid2Nfb3NfY2FydF9ub3RpY2VzIjthOjA6e31zOjExOiJ3Y19vc19ydWxlcyI7YTowOnt9czoxNzoid2Nfb3NfY2hpbGRfZW1haWwiO2E6MDp7fXM6MjM6IndjX29zX3NoaXBwaW5nX3NldHRpbmdzIjthOjA6e31zOjE2OiJ3Y19vc19ncm91cF9tZXRhIjthOjA6e31zOjE1OiJ3Y19vc19tZXRhX2tleXMiO2E6MDp7fXM6Mjc6IndjX29zX3ZlbmRvcl9yb2xlX3NlbGVjdGlvbiI7czowOiIiO3M6MjQ6IndjX29zX2FsbF91c2VyX3dpdGhfcm9sZSI7YjowO30=

    • This reply was modified 3 weeks, 6 days ago by rajath1724.

    What i need:
    Order 1: Product 1 , Product 2
    Order 2: Product 3 (this is set to exclusive)

    Please try Inclusive split method in this case.

    It will create two sub-orders, one order with selected items and second with non selected items. If you do not want two sub-orders you can turn On “Remove Items from Parent Order on Split?”

    • This reply was modified 3 weeks, 6 days ago by richiewatson.
    Thread Starter rajath1724

    (@rajath1724)

    @richiewatson

    AutoSplit: ON
    Product set to: Inclusive

    The result is still the same, it splits every product into a separate order.

    YToxMTp7czoyMjoid2Nfb3NfZ2VuZXJhbF9zZXR0aW5ncyI7YTo2OntzOjI2OiJ3Y19vc19kaXNwbGF5X2NoaWxkX251bWJlciI7czo1MToiWW91IHdpbGwgcmVjZWl2ZSBbTlVNQkVSX09GX0NISUxEX09SREVSU10gcGFja2FnZXMuIjtzOjIxOiJ3Y19vc19saW1pdF9hbHBoYWJldHMiO3M6MDoiIjtzOjIzOiJ3Y19vc19hdXRvX2Nsb25lX3N0YXR1cyI7czowOiIiO3M6MzA6IndjX29zX2N1c3RvbWVyX3Blcm1pc3Npb25fdGV4dCI7czoyODoiQ29uZmlybSB0byBzcGxpdCB5b3VyIG9yZGVyPyI7czoxNzoid2Nfb3Nfb3JkZXJfdG90YWwiO3M6MToiMSI7czoxNzoid2Nfb3NfYXV0b19mb3JjZWQiO3M6MToiMSI7fXM6MTQ6IndjX29zX3NldHRpbmdzIjthOjEzOntzOjg6IndjX29zX2llIjtzOjc6ImRlZmF1bHQiO3M6MjI6IndjX29zX3F0eV9zcGxpdF9vcHRpb24iO3M6NzoiZGVmYXVsdCI7czoxMDoiaW9fb3B0aW9ucyI7YTo2OntzOjE1OiJpbl9zdG9ja19zdGF0dXMiO3M6MDoiIjtzOjE2OiJpbl9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoxNjoib3V0X3N0b2NrX3N0YXR1cyI7czowOiIiO3M6MTc6Im91dF9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoyMDoib3V0X3N0b2NrX2F1dG9tYXRpb24iO3M6Mjoibm8iO3M6MTY6Im91dF9zdG9ja19hbW91bnQiO3M6MzoieWVzIjt9czoxNDoid2Nfb3NfcHJvZHVjdHMiO2E6Mzp7czo5OiJleGNsdXNpdmUiO2E6MDp7fXM6NzoiZGVmYXVsdCI7YToxOntpOjA7czoxOiIwIjt9czo5OiJpbmNsdXNpdmUiO2E6MTp7aTowO3M6MzoiMzY4Ijt9fXM6MjA6IndjX29zX2dyb3VwX3N0YXR1c2VzIjthOjA6e31zOjEwOiJ3Y19vc19jYXRzIjthOjE6e3M6MTE6InNwbGl0X3JhdGlvIjtzOjA6IiI7fXM6MTY6IndjX29zX2FkZGl0aW9uYWwiO2E6Mzp7czoxNzoic3BsaXRfc3RhdHVzX2xvY2siO3M6MDoiIjtpOjA7czo3OiJyZW1vdmFsIjtpOjE7czoxOiIwIjt9czoxODoid2Nfb3NfYWxsX3Byb2R1Y3RzIjtzOjA6IiI7czoxMzoid2Nfb3NfdmVuZG9ycyI7YTowOnt9czoxNzoid2Nfb3Nfd29vX3ZlbmRvcnMiO2E6MDp7fXM6MTY6IndjX29zX2F0dHJpYnV0ZXMiO2E6MDp7fXM6MjM6IndjX29zX2F0dHJpYnV0ZXNfdmFsdWVzIjthOjA6e31zOjIyOiJ3Y19vc19hdHRyaWJ1dGVzX2dyb3VwIjthOjA6e319czoxOToid2Nfb3NfY3V6dG9taXphdGlvbiI7YTowOnt9czoxODoid2Nfb3NfY2FydF9ub3RpY2VzIjthOjA6e31zOjExOiJ3Y19vc19ydWxlcyI7YTowOnt9czoxNzoid2Nfb3NfY2hpbGRfZW1haWwiO2E6MDp7fXM6MjM6IndjX29zX3NoaXBwaW5nX3NldHRpbmdzIjthOjA6e31zOjE2OiJ3Y19vc19ncm91cF9tZXRhIjthOjA6e31zOjE1OiJ3Y19vc19tZXRhX2tleXMiO2E6MDp7fXM6Mjc6IndjX29zX3ZlbmRvcl9yb2xlX3NlbGVjdGlvbiI7czowOiIiO3M6MjQ6IndjX29zX2FsbF91c2VyX3dpdGhfcm9sZSI7YjowO30=

    @rajath1724 in your settings it is set to default split status. Please select inclusive and save changes to apply selected method.

    Thread Starter rajath1724

    (@rajath1724)

    Is there something else I’m missing?

    Also I set the product to every other setting (default,inclusive,exclusive) and checked as well, it still splits every product into a separate order when Auto Split is ON.

    When Auto Split is OFF. It does nothing. Does not split the order regardless of what the product setting is.

    Thread Starter rajath1724

    (@rajath1724)

    @richiewatson It is set to inclusive.

    Please check loom video: https://www.loom.com/share/9e0986563c1e4747aec4447f6f8e1915

    YToxMTp7czoyMjoid2Nfb3NfZ2VuZXJhbF9zZXR0aW5ncyI7YTo2OntzOjI2OiJ3Y19vc19kaXNwbGF5X2NoaWxkX251bWJlciI7czo1MToiWW91IHdpbGwgcmVjZWl2ZSBbTlVNQkVSX09GX0NISUxEX09SREVSU10gcGFja2FnZXMuIjtzOjIxOiJ3Y19vc19saW1pdF9hbHBoYWJldHMiO3M6MDoiIjtzOjIzOiJ3Y19vc19hdXRvX2Nsb25lX3N0YXR1cyI7czowOiIiO3M6MzA6IndjX29zX2N1c3RvbWVyX3Blcm1pc3Npb25fdGV4dCI7czoyODoiQ29uZmlybSB0byBzcGxpdCB5b3VyIG9yZGVyPyI7czoxNzoid2Nfb3Nfb3JkZXJfdG90YWwiO3M6MToiMSI7czoxNzoid2Nfb3NfYXV0b19mb3JjZWQiO3M6MToiMSI7fXM6MTQ6IndjX29zX3NldHRpbmdzIjthOjEzOntzOjg6IndjX29zX2llIjtzOjc6ImRlZmF1bHQiO3M6MjI6IndjX29zX3F0eV9zcGxpdF9vcHRpb24iO3M6NzoiZGVmYXVsdCI7czoxMDoiaW9fb3B0aW9ucyI7YTo2OntzOjE1OiJpbl9zdG9ja19zdGF0dXMiO3M6MDoiIjtzOjE2OiJpbl9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoxNjoib3V0X3N0b2NrX3N0YXR1cyI7czowOiIiO3M6MTc6Im91dF9zdG9ja19oZWFkaW5nIjtzOjA6IiI7czoyMDoib3V0X3N0b2NrX2F1dG9tYXRpb24iO3M6Mjoibm8iO3M6MTY6Im91dF9zdG9ja19hbW91bnQiO3M6MzoieWVzIjt9czoxNDoid2Nfb3NfcHJvZHVjdHMiO2E6Mzp7czo5OiJleGNsdXNpdmUiO2E6MDp7fXM6NzoiZGVmYXVsdCI7YToxOntpOjA7czoxOiIwIjt9czo5OiJpbmNsdXNpdmUiO2E6MTp7aTowO3M6MzoiMzY4Ijt9fXM6MjA6IndjX29zX2dyb3VwX3N0YXR1c2VzIjthOjA6e31zOjEwOiJ3Y19vc19jYXRzIjthOjE6e3M6MTE6InNwbGl0X3JhdGlvIjtzOjA6IiI7fXM6MTY6IndjX29zX2FkZGl0aW9uYWwiO2E6Mzp7czoxNzoic3BsaXRfc3RhdHVzX2xvY2siO3M6MDoiIjtpOjA7czo3OiJyZW1vdmFsIjtpOjE7czoxOiIwIjt9czoxODoid2Nfb3NfYWxsX3Byb2R1Y3RzIjtzOjA6IiI7czoxMzoid2Nfb3NfdmVuZG9ycyI7YTowOnt9czoxNzoid2Nfb3Nfd29vX3ZlbmRvcnMiO2E6MDp7fXM6MTY6IndjX29zX2F0dHJpYnV0ZXMiO2E6MDp7fXM6MjM6IndjX29zX2F0dHJpYnV0ZXNfdmFsdWVzIjthOjA6e31zOjIyOiJ3Y19vc19hdHRyaWJ1dGVzX2dyb3VwIjthOjA6e319czoxOToid2Nfb3NfY3V6dG9taXphdGlvbiI7YTowOnt9czoxODoid2Nfb3NfY2FydF9ub3RpY2VzIjthOjA6e31zOjExOiJ3Y19vc19ydWxlcyI7YTowOnt9czoxNzoid2Nfb3NfY2hpbGRfZW1haWwiO2E6MDp7fXM6MjM6IndjX29zX3NoaXBwaW5nX3NldHRpbmdzIjthOjA6e31zOjE2OiJ3Y19vc19ncm91cF9tZXRhIjthOjA6e31zOjE1OiJ3Y19vc19tZXRhX2tleXMiO2E6MDp7fXM6Mjc6IndjX29zX3ZlbmRvcl9yb2xlX3NlbGVjdGlvbiI7czowOiIiO3M6MjQ6IndjX29zX2FsbF91c2VyX3dpdGhfcm9sZSI7YjowO30=

    @rajath1724 You have to select split method in the purple area first. Then select items according to the selected split method.

    You have selected Default method in the purple area that’s why it is splitting every item into a separate item.

    This is the screenshot from your clip. https://paste.pics/CMIHX

    Thread Starter rajath1724

    (@rajath1724)

    That was stupid of me, I’m so sorry for wasting your time on this. Did not realize that was a selectable thing.

    It works. Thank you very much @richiewatson

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.