WordPress.org

Forums

Authorize.net AIM Payment Gateway For WooCommerce
order-received endpoint 404 error (11 posts)

  1. cschear
    Member
    Posted 1 year ago #

    Upgraded to Woocommerce to 2.1.1. After a customer submits an order redirected to 404 error page. The pay page and thank you pages are no longer existent in 2.1.1, does your plugin still try to re-direct to them?

    https://wordpress.org/plugins/authorizenet-aim-payment-gateway-for-woocommerce/

  2. lbain
    Member
    Posted 1 year ago #

    I had the same issue and after staying up 2 days and all night I figured it out. For me it was the WP Video Plugin, but according to WooCommerce there can be many plugins that cause a problem, so make sure to go through them all.

    Steps
    STEP 1) Have the page that has the 404 error open in a separate tab or window so you can switch back and forth from the page to the dashboard.

    Note: My 404 pages are all the ones that changed from pages to endpoints ".../my-account/view-order/..."

    STEP 2) FLUSH PERMALINKS
    Go to settings > permalinks >
    Choose:
    Common Settings > post name
    Product permalink base > shop base
    Click Save

    Note: if these are already your settings just click save. Product permalink base will change to "custom base" after you save, it's ok as long as your base is "/shop" . Also I did this process many times but didn't realize each change I needed to flush the permalinks, I would have saved myself 2 days of work and now another day to get all the stuff back that I lost...

    STEP 3) Refresh the 404 page
    If the page does not load and continues to be 404 then continue

    STEP 4) Deactivate all plugins except woocommerce

    Repeat steps 2 & 3

    >If the page still reloads as 404 then it's probably not a problem with a plugin.
    >If the page loads as what it should be then go to step 5 to find the plugin that is causing an issue

    STEP 5) Activate one plugin
    STEP 6) Reload page that was 404 but now appears to be fixed

    >if it becomes 404 again then that plug in was the issue and it would be best to delete it if possible - because you really don't know if it will ever work with woocommerce again. - you will need to repeat step 2 and 3 - and your issue should be resolved.

    >if it stays the correct page (doesn't change back to 404) then that plugin was ok - in this case repeat steps 5&6 until you find the plugin that is the issue.

    notes: mine was the last one on the page and I kept thinking it must be something else, so I tried other things after going about halfway through my long list of plugins. It would have been worth the time to go through each plug in, because I delete woocommerce and some other plugins in desperation, not realizing my issue was really that I didn't find the problem plugin and then flush the permalinks. I didn't lose my products or orders, but I did lose some other stuff I need to now reinstall and fix the info I lost within woocommerce, but at least it's working and I don't have to start over.

    Hope this helps you

  3. golfinred
    Member
    Posted 1 year ago #

    This worked for me! Thank You!!

    The plugin that was causing me issues was 404 redirect.

  4. vitalvintage
    Blocked
    Posted 1 year ago #

    Did not work for me. Disabled all plugins. purge the permalinks. and nothing. sad to say.

  5. vitalvintage
    Blocked
    Posted 1 year ago #

    any help?

  6. vitalvintage
    Blocked
    Posted 1 year ago #

    guess no help then like every other post on here.
    heres the fix: find some russian site that has version 1.0 of the plugin. delete 2.0 then reinstall 1.0.
    2.0 plugin is only good for latest woocommerce version 2.1

  7. EnglishTutorsOnline
    Member
    Posted 11 months ago #

    Deactivating and reactivating all the plugins worked for me. I also had to follow the permalink instructions. Interestingly, I did not have to disable any plugin permanently: it seems that de/activating everything fixed the problem in and of itself.

    I should mention that I also had to reinstate my membership page/wc shortcode. I am using PMPro for membership, so there was a little conflict there, too, I think.

    Thanks everyone. Got this solved in about 3 hours...

  8. Ishan Verma
    Member
    Plugin Author

    Posted 11 months ago #

    I would suggest contact product support: http://www.wuxxa.com/product-support
    than experimenting on the live site to be on safer side.

    Thanks

  9. Flowrian
    Member
    Posted 10 months ago #

    I could fix this issue with deactivationg the plugin "404 Redirected".
    Now the pages work.

  10. andersonnarciso
    Member
    Posted 10 months ago #

    @Ibain

    This plugin is my problem.

    Simple Multisite Sitemaps

    A very simple solution for generating seperate Google XML Sitemaps for each WordPress site in a multisite network, on-the-fly.
    Versão 1.1 | Por Jan Brinkmann | Visitar o site do plugin

    Thanks for solution!

  11. Emanuel
    Member
    Posted 6 months ago #

    Thank you lbain. I flush permalinks and it's ok! ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.