Support » Plugin: WooCommerce Stripe Payment Gateway » Order moved to processing without validating payment

  • Resolved stylise

    (@stylise)


    I had an order get marked as “Payment via Credit Card. Paid on September 18, 2021 @ 2:00 pm” but no credit card payment actually processed.

    The only reason I caught this was because our shipping software displayed the “Total Paid” field as “$0.00”. After checking with Stripe, there was in fact no record of a credit card payment for this order.

    We successfully processed other credit card payments on this day. I wonder if it could have been an exploit. Either way, this is very worrying.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Con a11n

    (@conschneider)

    Automattic Happiness Engineer

    Hi there,

    We successfully processed other credit card payments on this day. I wonder if it could have been an exploit. Either way, this is very worrying.

    There is a very slim chance that it could be but what happens much more frequently is that the transaction gets interrupted. For example your customer closes their browser window or your server has a slight hiccup and crashes the process or the communication to Stripe gets derailed.

    Did the order status of that affected order say “Pending Payment”?

    Kind regards,

    Thread Starter stylise

    (@stylise)

    The order status automatically changed from “pending payment” to “processing” without a Stripe charge note or any charge ID.

    If I remember correctly, pending payments move to processing once they have been paid for, or to cancelled if 30 minutes has passed without payment.

    Plugin Support 3 Sons Development – a11n

    (@3sonsdevelopment)

    Hey @stylise,

    We have had a few reports of this happening to sites where the order total would be $0 and the order set to “processing” without actually charging the customer. It’s been a very intermittent issue affecting maybe one out of several dozen orders.

    Could I get you to open up a ticket for us about this? Please make sure to include the system status report too. You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, you can paste it here.

    https://woocommerce.com/my-account/create-a-ticket/

    Thanks!

    Thread Starter stylise

    (@stylise)

    @3sonsdevelopment Just opened a ticket, thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Order moved to processing without validating payment’ is closed to new replies.