Support » Plugin: PayPal for WooCommerce » Order information missing; payment does not complete

  • We have been seeing some orders come through with billing and shipping info missing, and payment not completed. Note that billing ands shipping info is in the database, but not in the transaction. This does not happen on every transaction. This began happening on January 18.

    Today, there were two. Info from log:

    2019-01-23T02:55:34+00:00 INFO PayPal for WooCommerce Version: 1.5.7
    2019-01-23T02:55:34+00:00 INFO WooCommerce Version: 3.5.4
    2019-01-23T02:55:34+00:00 INFO Test Mode:
    2019-01-23T02:55:34+00:00 INFO PayFlow Endpoint: https://payflowpro.paypal.com
    2019-01-23T02:55:34+00:00 INFO PayPal for WooCommerce Version: 1.5.7
    2019-01-23T02:55:34+00:00 INFO WooCommerce Version: 3.5.4
    2019-01-23T02:55:34+00:00 INFO Test Mode:
    2019-01-23T02:55:34+00:00 INFO PayFlow Response: Array
    (
    [RESULT] => 0
    [PNREF] => AF3E1B2B1046
    [RESPMSG] => Verified
    [AUTHCODE] => 227546
    [CVV2MATCH] => Y
    [HOSTCODE] => 00
    [RESPTEXT] => APPROVAL 227546
    [PROCAVS] => 0
    [PROCCVV2] => M
    [CCTRANSID] => 006654064011271
    [AMEXID] => 006654064011271
    [AMEXPOSDATA] => 160950V00130
    [CCTRANS_POSDATA] => 160950V00130
    [TRANSTIME] => 2019-01-22 18:55:33
    [BILLTOFIRSTNAME] => XXX
    [BILLTOLASTNAME] => XXX (name removed by me)
    [AMT] => 0.00
    [ACCT] => 1003
    [EXPDATE] => 0621
    [CARDTYPE] => 3
    [VALIDATIONCODE] => NV1
    [IAVS] => N
    [ORDERID] => abashop_6398
    [RAWREQUEST] =>

    Please advise.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Oliver

    (@angelleyesupport)

    Hi @geneise ,

    These must be order which were not completed or the users may have some issue with the Payment. or they simply changed their mind and did not move further.

    Did you see any error associated to these orders? If not then you should talk to these specific customer and take their feedback about the experience they have. That may help us figure out where they were stuck and if there will be something on our end fix, We will be more than happy to help.

    Thanks!

    Thread Starter Greg Neise

    (@geneise)

    They completed the order(s). Information that is collected at checkout is in the database, … but not in the order, and of course, there was no payment collected.

    Confirmation emails were sent, but transaction was not completed:

    New Order: #6398
    You’ve received the following order from :
    [Order #6398] (January 22, 2019)
    Product Quantity Price
    ABA Tropicbird Pendant with Sterling Chain (#pendant) 1 $60.00
    ABA Luggage Tag (#luggage tag) 4 $12.00
    ABA Tropicbird Earrings (#earrings) 1 $40.00
    Subtotal: $112.00
    Shipping: Priority Mail Medium Flat Rate Box
    Tax: $0.00
    Total: $0.00

    We have contacted some of the customers, and they thought that their order went through. This has happened 5 times (4 different people) since January 18 (none before).

    ###

    It has now happened to one customer twice. Looking a little closer, all of the transactions with this problem have this in common:

    [tender] => C
    [trxtype] => A

    I also notice that successful transactions have [custom] filed that looks like this:

    [custom] => {“order_id”:6362,”order_key”:”wc_order_5c4119c728d07″}

    … and problem transactions, like this:

    [custom] => {“order_id”:6364,”order_key”:””}

    And, sales that go through successfully:

    [RESPMSG] => Approved

    …vs problem transactions:

    [RESPMSG] => Verified

    Please advise.

    • This reply was modified 3 years, 5 months ago by Greg Neise.
    Plugin Contributor Oliver

    (@angelleyesupport)

    @geneise Thanks for the feedback, we are looking into this and will get back to you asap.

    Thanks!

    Plugin Contributor angelleye

    (@angelleye)

    @geneise It sounds like the orders where this is happening is because it was set to Authorization instead of Sale.

    If this only happening on some orders, then I would say you must have this set differently at the product level.

    To clarify, under Settings -> PayPal for WooCommerce -> PayFlow, you’ll find the option for “Payment Action” which can be set to Authorization or Sale. This would be treated as a global setting that would be the default for all of your orders.

    Within the product editor, where you see the side tabs for General, Inventory, Shipping, etc. you will find a tab called Payment Action. Within that, you could check to enable it, and then select Authorization or Sale. This would take affect for that product, and would override the global setting.

    So one way or another, it sounds like you have some orders that are getting processed as Authorizations. This looks to the buyer like it completes, and it shows up in WooCommerce as a pending authorization. This also explains why your response log shows RESULT 0 (which means successful) and a PNREF (which is the transaction ID for the Authorization.) This is also what the TRXTYPE=A means.

    So that seems to be what’s happening, but you’ll need to double check your settings to figure out what is triggering it.

    Please take a look at those things and let me know if that helps. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Order information missing; payment does not complete’ is closed to new replies.