Support » Plugin: WooCommerce » Order email functionality error

  • Resolved Prashant Dave

    (@prashantdave1610)


    When I set the order action to “email invoice/order details to customer” and press update at that time email sent to customer but the email fails to sent because to email address is used customer’s email address instead of admin email address.
    My server is not able to detect customer’s email address and email sending failed.
    What should I do to change the email address from customer’s email address to admin email address?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Prashant Dave

    (@prashantdave1610)

    Please help as soon as possible because I am going to launch my web store around 16th august and this issue delays it’s launching.

    Why am I receiving messages for every comment that has conversation going right now?

    Plugin Author Gerhard Potgieter

    (@kloon)

    @prashantdave1610 The email invoice/order details to customer option uses the email address of the customer on the order for sending the email. This would be the emails listed here on the order https://cld.wthms.co/JNbB1a

    If you want to send the email to the store admin you need to use the Resend new order notification option from the list. This will then send the email to the address entered in WooCommerce -> Settings -> Emails -> New Order under the Recipient(s) option.

    If emails are not arriving at all have a read through our Email FAQ which will aid in debugging emails not sending issues https://docs.woocommerce.com/document/email-faq/#section-4

    Prashant Dave

    (@prashantdave1610)

    @prashantdave1610 The email invoice/order details to customer option uses the email address of the customer on the order for sending the email. This would be the emails listed here on the order https://cld.wthms.co/JNbB1a
    -> This is the problem. Woocommerce try to send email with from address of customer email address and my server declines to send from that email address. Because the customer’s email address is of gmail and my server can not send emails as it’s not gmail it is shopitarea.com

    Prashant Dave

    (@prashantdave1610)

    Please help to solve the issue.

    Prashant Dave

    (@prashantdave1610)

    Problem is that my server refused to send email with from address not belong to my domain. That’s why I need that all email sent with from address of my admin email.
    And woocommerce uses customer’s email address as from address and in this case my server refused to send email.

    Prashant Dave

    (@prashantdave1610)

    Please hurry as this issue is delaying my web store launching.

    Plugin Author Gerhard Potgieter

    (@kloon)

    @prashantdave1610 It seems the emoji in the additional text section is the cause of this error. To save the settings you can change your settings and just remove the hands up emoji before saving and all should save fine.

    We are busy looking into why the emoji might cause issues for some installations, it is likely something to do with the database encoding.

    Prashant Dave

    (@prashantdave1610)

    I don’t understand what are you saying.

    I have checked whole edit order page and not able to find any additional text section or any emoji.

    Please read whole thread carefully because the issue I phase is related to the emails.

    When I try to send email using order actions at that time email sending fails as from email address is taken of customer’s email address. It should use admin email address.

    Problem is that customer’s email address is not belong to my domain and my server refuses to send email which from address is not belong to my domain.

    For example: Customer’s email address is xyz@gmail.com
    Thus, system try to send email in which from email address is xyz@gmail.com
    And this email address is belong to gmail, not to my domain and server refuses to send email.
    Instead of customer’s email address it should use admin email address which belongs to my domain and server will send email.

    I hope now you can understand the issue.

    Prashant Dave

    (@prashantdave1610)

    Kindly give me solution as this issue delaying my website launching.

    Plugin Support Andrew

    (@slash1andy)

    Automattic Happiness Engineer

    Hey there!

    There’s not really a setting or an easy way to change the “from” email in this case. It would require some customization.

    I would recommend in your case to work with your host to get this sorted to allow sending like that, or to use an alternate solution to sending emails.

    * http://sendgrid.com/http://wordpress.org/plugins/wp-sendgrid/
    * http://www.mailgun.com/http://wordpress.org/plugins/mailgun/

    You can also use a plugin called WP Mail SMTP(https://wordpress.org/plugins/wp-mail-smtp/)

    Hopefully that helps! Have a great one!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.