Support » Plugin: Store Toolkit for WooCommerce » Order creation working no more

  • I nuked all my orders and now I cannot create any more new orders in woo. Ordering on website also doesn’t work. It has totally broken down the ordering system.

    I uninstalled and re-installed woo, but no luck. I cannot completely delete woo data for many reasons.

    I need to fix this asap, how do I re-store ordering function on my woo ?

    https://wordpress.org/plugins/woocommerce-store-toolkit/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Michael Visser

    (@visser)

    Hi bling007, if you de-activate Store Toolkit does your ordering function return to normal? If not then it’s another issue unrelated to ours.

    Can you check your PHP error log for any notices or fatal PHP errors that can help identify why your ordering function is not working.

    Thread Starter bling007

    (@bling007)

    Seriously? It is not. Its definitely your plugin. Plus, today itself there was a woocommerce update to new version.

    I have a bad feeling that it might be due to that.

    I get this error when I open Store-toolkit:

    It looks like a previous nuke failed to clear that dataset, this is common in large catalogues and is likely due to WordPress hitting a memory limit or server timeout. Don’t stress, retry Order nuke?

    And it still shows that I have 7 more orders to Nuke when the reality is I have none showing in my orders in woo.

    Please advice me how I can undo all this.

    Again, I did deactivate the plugin, the order system doesn’t work. It doesn’t need advice that I should have tried doing that.

    help me create a dummy order so that I can get it back live ! So whatever it takes, I just need it to run normally again.

    Thread Starter bling007

    (@bling007)

    The “add order” redirects me to post.php link which leads to white screen.

    When ordered on site, it redirects me to wrong order-received page. The page used to show order details early on. Now it just says Thank you.

    The plugin however detects orders created by “add-order” option in admin, but these orders are not visible. Trying to delete these orders through the plugin doesn’t help AT ALL.

    Early on everything used to work.

    I highly doubt its anything else cause I had thoroughly tested entire setup.

    Your plugin never gives completed message when Nuking orders.

    I “trashed” an order while editing an order created via “add-order” (manually), it does show up in trash section. However, the row-actions are missing.

    Plus, restore that order redirects straight-away to “Posts” section. Its not even a woocommerce thing.

    Its driving me nuts the way its going, please HELP !!!

    Thread Starter bling007

    (@bling007)

    The “add order” redirects me to post.php link which leads to white screen.

    I meant saving the order generated by “add order” redirects to white screen with url having post.php at the end.

    Plugin Author Michael Visser

    (@visser)

    Hi bling007, shoot me an e-mail at michael@visser.com.au, I’m happy to help you, I’ll be testing our Plugin against the latest 2.4.* release today.

    Plugin Author Michael Visser

    (@visser)

    On 31/10 a user of our Plugin contacted me experiencing the above issue, I’m working with them to isolate this but suspect the transition to the custom WooCommerce Post Status is failing for very isolated stores. There are 4000+ active Users of this Plugin and only 2 known instances of this happening (blind007 has not contacted me so I assume this has been resolved).

    If anyone is experiencing the above issue please contact me directly at michael@visser.com.au so I can look into this with you.

    Hello all,
    One question I have is do I need the store tool kit or do I just upload the woo ecommerce plug in and us that? OR do I need both installed to start selling, what’s the difference between the two?
    Thank you!
    Tom
    http://www.JamminJunior.com

    Plugin Author Michael Visser

    (@visser)

    Hi Tom, you’ll need to install and activate WooCommerce to be able to use our Plugin.

    This is exactly the issue we have been battling with, following nuking the orders, any imported orders or new orders created get removed.
    Looking at the database, the orders are there, but in dashboard it shows zero orders.

    Thank you for sharing your email Michael, I will send you an email right now as any help to resolve this would be gratefully received.

    Thanks,

    Duncan.

    I have exactly the same issue. It is not isolated case. Please, publish solution here ASAP. This is a severe crash making orders not working anymore.
    Thanks.

    Hi,

    I have the exact same error. I’ve send you an e-mail. I would suggest putting the solution here because I too have a deadline for this project and now the whole order system is broken.

    Thanks in advance,
    William

    Plugin Author Michael Visser

    (@visser)

    Hi guys, just chasing this ongoing topic. You will need to repair the Posts table using phpMyAdmin as it has been corrupted, you may also need to override the auto-increment counter. This is how I resolved the issue of new Orders not showing up in the storefront or WP Admin.

    I haven’t been able to reliably reproduce this as it seems to require a special sauce to successfully corrupt the wp_posts table. As mentioned to William this morning via e-mail I still don’t understand how I caused it as I used WordPress resources to delete Posts but the volume of records deleted might have been enough to trip the database up, this is why I haven’t pushed a Plugin update to resolve it as I can’t reproduce it every time.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Order creation working no more’ is closed to new replies.