Support » Fixing WordPress » OracleJDK | OpenJDK

  • teflonmerkel

    (@teflonmerkel)


    Hi,

    today I got an E-Mail from my webhoster.

    They told me that they are switching the Java interpreter from OracleJDK to OpenJDK on our webserver.

    Now my question. Is WordPress Version 5.0 fully compatible with OpenJDK?
    Further I am running two themes (Divi (From Elegant Themes) and the Newspapertheme (From Tag Div))?

    Does anyone know if these themes are compatible with OpenJDK?

    Or do I get some “weird” effects if they are changing the JDK early next year?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @teflonmerkel! I don’t believe this change should affect WordPress or your themes.

    WordPress is not built on Java but rather with PHP, HTML, CSS, and JavaScript. PHP is a language that runs on the server, and HTML, CSS, and JavaScript are language read and run by the browser. Despite the fact that “JavaScript” contains the word “Java”, JavaScript is an independent language that does not rely on Java or its platform.

    Does that answer your concerns?

    teflonmerkel

    (@teflonmerkel)

    Thanks for your quick reply.
    One further question.

    Do you know if Oracle plans to charge any fees for the “normal” Java addon for webbrowsers in future?

    If yes are there any alternatives?

    Thanks for your efforts in advance.

    Best regards,

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Moved to Fixing WordPress, this is not a Developing with WordPress topic.

    Do you know if Oracle plans to charge any fees for the “normal” Java addon for webbrowsers in future?

    No idea and these are WordPress support forums. That part isn’t for here.

    WordPress uses Javascript and does not use Java (the names are a thing I know) at all. The JDK is about Java, not Javascript. It has nothing to do with WordPress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.