Support » Plugin: EWWW Image Optimizer » optipng path: gifsicle path: pngout path: ALL BLANK

  • Resolved serkis

    (@serkis)


    I have optipng and gifsicle in the /wp-content/ewww directory but its not “seeing” it, but its seeing jpegtran
    ===============================================
    jpegtran: UPDATE AVAILABLE* Install automatically | manually version: Independent JPEG Group's JPEGTRAN, version 8b 16-May-2010
    optipng: MISSING Copy binary from /hermes/bosweb25a/b209/nf.XXXX/public_html/blog/wp-content/plugins/ewww-image-optimizer/ to /hermes/bosweb25a/b209/nf.XXXX/public_html/blog/wp-content/ewww/ or Download optipng source
    GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Operating System: Linux
    Debug Info

    jpegtran path: jpegtran
    optipng path:
    gifsicle path:
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    user: nf.XXXX

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 15 replies - 16 through 30 (of 36 total)
  • When I go to wp-content/ewww and run ./optipng -v, I get:

    OptiPNG version 0.7.4
    Copyright (C) 2001-2012 Cosmin Truta and the Contributing Authors.

    This program is open-source software. See LICENSE for more details.

    Portions of this software are based in part on the work of:
    Jean-loup Gailly and Mark Adler (zlib)
    Glenn Randers-Pehrson and the PNG Development Group (libpng)
    Miyasaka Masaru (BMP support)
    David Koblas (GIF support)

    Using libpng version 1.4.12 and zlib version 1.2.7-optipng

    This shows the newest version exists in the directory, however it still not being used by the plugin. I tried following your instruction and run “yum install glibc.i686”, however, the package was already installed.

    Plugin Author nosilver4u

    (@nosilver4u)

    And you don’t have the setting checked to ‘Use system paths’?

    Thank you again for your reply. “Use system paths” is unchecked.

    without calling my webhost support I was able to grab this info

    Platform Type: Debian
    MySQL Version: 5.0.91-log
    Perl Version: 5.8.8
    PHP Version: 5.3.13
    Path to PHP: /usr/local/bin/php

    also running WordPress 3.4.2.
    about to upgrade to 3.5

    1 suggestion the error is

    optipng: MISSING Copy binary from /hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/plugins/ewww-image-optimizer/ to /hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/

    but on my webhost for security reasons obviously I can only see inside
    /hermes/bosweb25a/b209/nf.stmarytoronto/, so in other words I can’t navigate from the true root

    perhaps the plugin is also under the same restrictions???

    Plugin Author nosilver4u

    (@nosilver4u)

    serkis, 2 questions:
    1. do you have command line (shell) access, so that you could browse to the wp-content/ewww/ folder and run ‘optipng -v’ ?
    2. can you see if Debian is using 64-bit or 32-bit?

    1.no shell access
    2. Linux 2.6 Debian Lenny (v5.0) – 32 bit

    Plugin Author nosilver4u

    (@nosilver4u)

    serkis, that might explain why it doesn’t work then. Debian 5 is old enough that it probably has an older kernel than centos 5, and thus the bundled tools are incompatible. I wasn’t sure anyone was still using Debian 5. At any rate, I’ll see if I can setup a VM with that and re-compile the tools.

    andre, I’m still working on my centos6 VM to try and replicate your issue.

    That’s okay, nosilver4u! 😉

    You got the same issue in your VM?

    Plugin Author nosilver4u

    (@nosilver4u)

    not yet, just finished installing it. I’ll probably work more on it Monday.

    Plugin Author nosilver4u

    (@nosilver4u)

    andre,
    After doing sudo yum install glibc.i686 everything works fine for me on centos6. Can you paste the output of this command:

    ls -l /var/www/html/wp-content/ewww/

    Hi,

    ls -l /var/www/html/wp-content/ewww/ output:

    total 3080
    -rwxr-xr-x 1 apache apache 923929 Jan 18 15:52 gifsicle
    -rwxr-xr-x 1 apache apache 797153 Jan 18 15:52 optipng
    -rw-r–r– 1 root root 667776 Jan 18 16:22 optipng-mac
    -rw-r–r– 1 root root 739504 Jan 18 15:55 pngout-static

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, let’s try a test…

    Create a file named test.php and insert this code:

    andre:

    <?php
    echo shell_exec('/var/www/html/wp-content/ewww/optipng -v 2>&1');
    echo "<br>";
    echo shell_exec('/var/www/html/wp-content/ewww/gifsicle --version 2>&1');
    ?>

    serkis:

    <?php
    echo shell_exec('/hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/optipng -v 2>&1');
    echo "<br>";
    echo shell_exec('/hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/gifsicle --version 2>&1');
    ?>

    If there is any output, please post the url to the test.php file so I can see it for myself.

    Plugin Author nosilver4u

    (@nosilver4u)

    Another possibility, add this code below the last:

    <?php
    echo "<br>" . shell_exec('file 2>&1');
    ?>

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘optipng path: gifsicle path: pngout path: ALL BLANK’ is closed to new replies.