OptionTree Textarea not stripping slashes on output (1 post)

  1. Ryan
    Posted 3 years ago #

    I'm having trouble with a textarea option using the OptionTree plugin. It appears that the value isn't being stripped of slashes when the value contains double-quoted attributes.

    For example:

    I input:
    <strong style="font-size:22px;">Test</strong>

    When I print the output in a theme file I get:
    <strong style=\"font-size:22px;\">Test</strong>

    I've tried stripping slashes before printing the variable in the theme, but that doesn't seem to solve the problem.

    I saw a related issue that indicates this was fixed a year ago. Was the error reintroduced?

    Thanks much for any advice anyone can offer. And thanks to the developer for this otherwise fantastic plugin.


    UPDATE If I run the variable through stripslashes() twice, it works. Seems inefficient though, so am hoping there's a better solution.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • OptionTree
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic