Support » Plugin: Wordfence Security - Firewall & Malware Scan » Options -ExecCGI making Error 500

  • Resolved 18TommyBoy

    (@18tommyboy)


    No updated the page half year… I don´t have time. Yesterday I not see the logo of page… Hm… I write to hosting admin, and he say:
    [Sat Oct 28 22:08:20 2017] [alert] [client xxx.xx.xx.xxx] /web/htdocs3/my_sitecom/home/www/wp-content/uploads/.htaccess: Option ExecCGI not allowed here

    When I //commented this line, all images and is back. What is this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • htaccess file:

    # BEGIN Wordfence code execution protection
    <IfModule mod_php5.c>
    php_flag engine 0
    </IfModule>
    <IfModule mod_php7.c>
    php_flag engine 0
    </IfModule>
    
    AddHandler cgi-script .php .phtml .php3 .pl .py .jsp .asp .htm .shtml .sh .cgi
    Options -ExecCGI
    # END Wordfence code execution protection
    

    Hi,
    This code snippet belongs to “Disable Code Execution for Uploads directory” option, I assume your server is using FastCGI that’s why your hosting provider mentioned that “Option ExecCGI not allowed here”, hence I’m afraid to tell that this feature won’t work as it should on your server for now unless your provider used AllowOverride Options in Apache server configuration for this directory “uploads”, you can send them this guide as a reference.

    Thanks.

    Hello!

    I hope we were successful in helping you resolve your issue with Wordfence! Since we have not heard back from you in the past 2 weeks I will now be marking this support thread as resolved. However, if we still haven’t resolved your issue please reach out to us as we would be more than happy to further assist you!

    Thanks and have a great day!
    Chloe

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Options -ExecCGI making Error 500’ is closed to new replies.