Support » Plugin: WP Document Revisions » Options / Checkout / Revisions & PDF issues w/ version 3.2.4

  • Hello,

    Several issues with Version 3.2.4 on WordPress 5.3.2:
    I am in Eastern Time Zone in USA, which WordPress sees as -5 / New York. Anytime there is a document version update posted, the time posted for that revision is “5 hours ago” and it’s entered DOUBLE in the revision history.

    When changing Options like the option where to save the files (instead of the wp-content/uploads folder), the option just doubles itself and I have to go to the database to fix it proper.

    Once I upload a new revised file, ALL previous revisions will change to that file, so if I try to go back to a previous file revision, it will only post the recent PDF file.

    This is an INTRANET so I cannot post our local URL

    Also, PDF links only work with ugly permalinks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • @hammsilv
    Thanks for your report. You raise several issues. I will give several replies to separate them out.

    Your first paragraph – Time Zone and Human_Time_Diff.
    This is where it outputs “5 hours ago”. There is a bug in the software. May (or may not) now be visible because WP 5.3 fixed and standardised datetime processing.

    Your first paragraph – Entered DOUBLE in revision history.
    This has been raised before (see for example
    New Document Saves Twice)
    It is an artefact of the plugin.
    Possibly, the restore options should be removed from the first two entries as it makes little sense to have them. Also autosaves can mess with the apparent numbering causing gaps in the revision numbers shown.

    Regards,
    Neil James

    @hammsilv
    For your second paragraph on options.

    Under Settings->Media there are the standard options (if not multisite)

    Store uploads in this folder
    Full URL path to files

    and the checkbox about uploads being organised in year/month sub-folders

    When you activate the plug-in it adds two new settings

    Document Upload Directory
    Document Slug

    By default, Documents are loaded into the standard upload folder. So if you don’t want to separate them from Media then there is no need to change it. However this will expose the file names to all users that can see the Media library, so normally you do want to add a different directory.

    There is metadata for each document saved that gives only the sub-folder.

    When you enter and save a value into the upload directory name, this has three effects:

    1. Media remains within its directory.
    2. All new documents will be loaded into the document upload directory – provided it exists and has the necessary permissions.
    3. It will think that all existing documents and revisions are loaded in this document directory.

    Unless you have taken some action with the file system to make the existing documents available in the new document directory, no existing document will be available.

    Please can you explain in more detail what you have done and how you needed to resolve the problem.

    Thanks for clarification,
    Neil James

    Hello,

    Under Settings > Media, I can find the “Uploading Files” option. My issue is that whenever I change the “Document Upload Directory” field, the field then repeats the entry. Allow me to offer more details.

    Right now, my entry in that field is the default one,

    C:\inetpub\wwwroot\wp/wp-content/uploads

    I want to change the Uploads folder to HVRDocs

    C:\inetpub\wwwroot\wp/wp-content/HVRDocs

    When I submit the changes, the resulting entry in the field is

    C:\inetpub\wwwroot\wp/C:\inetpub\wwwroot\wp/C:\inetpub\wwwroot\wp/wp-content/HVRDocs

    At that point, I have go into the database to fix it, or I will not be able to upload any files whatsoever (I will get an error). I will find the option_name to be document_upload_directory inside the wp_options table. I have to change the option_value from

    C:\inetpub\wwwroot\wp/C:\inetpub\wwwroot\wp/C:\inetpub\wwwroot\wp/wp-content/HVRDocs

    to the correct one

    C:\inetpub\wwwroot\wp/wp-content/HVRDocs

    @hammsilv
    Thanks for your rapid reply.

    I have done all my WordPress work using Linux-based installations. So when I tried to replicate it there, I was unable to find it.

    So this morning I installed a WAMP installation of WordPress together with the plug-in.

    I got a similar error – and assume that it will be something to do with the \ character being used. I would guess that this issue has been around a while.

    Regards,
    Neil James

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Options / Checkout / Revisions & PDF issues w/ version 3.2.4’ is closed to new replies.