Support » Plugin: 404 Solution » Options changes don’t save properly

  • Resolved AutoBodyShop

    (@autobodyshop)


    Picking another page as default 404 and hitting “Save Settings” … leads me to the default 404 page: 404 – Ooops, page not found Sorry, but the requested page is not found. You might try a search below.

    It actually happens with ANY change I try to make on the “Options” page.

    I already deactivated all other plugins – especially the cache related ones … but to no prevail.

    Your debug report does not show any errors because loading the default 404 isn’t really an error, isn’t it.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Aaron

    (@aaron13100)

    What is the URL of the page you arrive at that gives you the 404 error?

    For example, do you start at
    /wp-admin/options-general.php?page=abj404_solution&subpage=abj404_options
    and then when you click Save do you end up at
    /wp-admin/options-general.php?page=abj404_solution&subpage=abj404_options&_wpnonce=86221af836
    ?

    Or do you end up at /some-unrelated-URL/ ?

    Yes, I’m starting at
    wp-admin/options-general.php?page=abj404_solution&subpage=abj404_options

    and end up at
    /wp-admin/options-general.php?page=abj404_solution&subpage=abj404_options&_wpnonce=df12a7f97c

    Plugin Author Aaron

    (@aaron13100)

    It sounds like the 404 Solution plugin isn’t being called at all. Have you tried uninstalling and reinstalling the plugin?

    Have you changed the “The 404 Solution menu should appear” option by any chance? Try changing that to the other setting perhaps.

    Just tried both … to no prevail.

    Plugin Author Aaron

    (@aaron13100)

    The next step is editing the source code to insert lines such as

    $abj404logging->errorMessage("Made it this far 1");

    to figure out if the plugin is actually being called or not and if so, where it stops responding. You can accomplish that with instructions, custom code to install, or by giving me access to your website. The options are listed in order by the amount of time it will take both of us, from most to least. Let me know how you’d like to proceed.

    Hi Aaron; Sorry about the late reply. I already chose another 404 plugin but would like to give it a shot with yours again as the features and functionality really beat most other plugins. On quite a few other sites of mine it’s working. The site in question and another one are actually both hosted on NameCheap … so I’m wondering if anything on their shared hosting servers is causing the issues. Either way: How can I privately provide you with access info?

    Plugin Author Aaron

    (@aaron13100)

    You can use the email address aaron@wealth-psychology.com

    Plugin Author Aaron

    (@aaron13100)

    Unfortunately I was unable to solve this. If anyone else has the same issue let me know on a new thread.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Options changes don’t save properly’ is closed to new replies.