Support » Fixing WordPress » Option to Comment missing

  • I activated the Comments and now nobody can comment. The option on my pages is missing. I am have a checked settings, even tried adding a comment plugin, but nothing is fixing this. I have since uninstalled a comment plugin and tried another, and it is still the same. Only option I see now is to uninstall Jetpack plugin.

Viewing 6 replies - 1 through 6 (of 6 total)
  • What’s set in your Settings->Discussion ? Is Allow people to post comments on new articles checked ?

    Yes, it is set. It was working. My first comment was made on the About page and it still shows not only the comment, but the option to add a comment.

    I have an e-Commerce theme. Since I am not ready to open the store yet, (still need approval for the merchant account), I have the settings now to have no static home page. This is the way it has been all along.

    I also have tried to add a comment plugin that would allow people to be rated for their comments, which is supposed to help with the store as well as the blog. It did not fix the problem either. It is now gone.

    I was also able to upgrade my theme to the new version as of today, but that did not fix the issue.

    Does it happen with all plugins deactivated and with the Twenty Twelve theme activated ?

    I do not use the Twenty Twelve theme. I am using Massimo eCommerce 2.2.2 from from I have not deactivated all my plugins. I deactivated Jetpack. I deactivated the program for comments and then uninstalled it.



    Forum Moderator

    Then have you asked the developers of the theme?

    Let me put it this way: you’re using a commercial theme so you should ask the theme author for support.
    In order to see if it’s your theme’s fault you should switch to the Twenty Twelve theme to exclude any theme related issues. The same goes for plugins. So, start the basic troubleshooting, please.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Option to Comment missing’ is closed to new replies.