Support » Plugin: Keywords to Links Converter » Option “dofollow” ignored, rel=”nofollow” always added to links

  • Issue
    =====
    Links are always created with rel=”nofollow” tag, making them invisible to search engines, even if corresponding setting “nofollow” in a single link or global setting is enabled.

    Please have a look at function ‘lar_auto_replace_links’ in public/class-lar-public.php.

    Reason
    ======
    Post meta contains an key named ‘_lar_links_do_follow’ which is either set to on/off, but it is checked of 1/0.

    Workaround
    ==========
    Please change the following condition public/class-lar-public.php:131 from

    
                            if($link_dofollow != 1){
                                    $dofollow = 'rel="nofollow"';
                            }
    

    to

    
                            if($link_dofollow != 'on'){
                                    $dofollow = 'rel="nofollow"';
                            }
    

    and it should work.

    Cheers,

    Matthieu

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Option “dofollow” ignored, rel=”nofollow” always added to links’ is closed to new replies.