Support » Plugin: Wordfence Security - Firewall & Malware Scan » Optimize WordFence Firewall

  • Resolved jedimoff


    I am trying to optimize the wordfence firewall on a godaddy managed wordpress website that already had it optimized before but now says it needs to be optimized again.

    It says it us auto prepend file to this file


    And I don’t recognize the file or the path to the file.

    And in the instructions it says to post here about it before proceeding.

    Any advice?



Viewing 4 replies - 1 through 4 (of 4 total)
  • Chiming in because I’m having the exact same issue with the same file. I don’t recognize the path, but the file is wordfence-waf.php

    Plugin Support wfphil


    Hi @jedimoff

    We have seen a few GoDaddy customers where GoDaddy have been modifying the absolute file path for customers hosting accounts.

    Then we have seen the new absolute file path for customers hosting accounts being reverted back to the old file path.

    Please note these reversion may have already taken place if you are suffering from the same issue.

    If not, then in the root directory of your WordPress installation you should see these two files:


    In the .user.ini you will see this code below with an example absolute file path:

    ; Wordfence WAF
    auto_prepend_file = '/absolute/path/to/wordfence-waf.php'
    ; END Wordfence WAF

    Remove that code.

    Now delete the wordfence-waf.php file.

    Load the Wordfence All Options page. Expand the Basic Firewall Options section and you can now optimize the firewall again.

    @jillyj please note that you may not have the exact same issue so as per forum rules it is always best to open your own topic for any issues that you are having.





    Plugin Support wfphil


    Hi @jedimoff

    You’re welcome!

    It sounds as though this is resolved so I will mark this topic as resolved for you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Optimize WordFence Firewall’ is closed to new replies.