Support » Plugin: Autoptimize » Optimize CSS Code making content spacing wrong

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    hey @jamiek47;
    1. make sure to disable WP fastest cache’s minify features (minifiers are jealous)
    2. if that does not fix, try adding wp-content/themes/delicacy/style.css to the comma-separated CSS optimization exclusion list.

    hope this helps,
    frank

    Hi Frank,

    Thanks, the second option works, but when I do this I get many more Google PageSpeed score errors for CSS files minified and JS file strangely although I didn’t select any options for JS?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Clearly excluding that style.css would make GPSI complain, but I indeed don’t see how this would trigger more JS-warnings. I’ll be happy to review if you have these changes live though.

    frank

    Hmmm, strange this first time I tested it throws JS wanrings, then if I test again it doesn’t. Maybe something to do with caching?

    I have Optimize CSS Code enabled and Inline and Defer CSS but I am still getting render blocking CSS and the CSS not minified error, please see here https://image.ibb.co/b1U1uv/autoptimizeon.png

    What can I do about these?

    Thanks,
    Jamie

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well;
    1. disable WPFC’s minification options (the 2 files singled out by GPSI are WPFC’ed minified CSS files)
    2. your “critical css” is not OK, have a look at this vid for info on how to extract critical CSS;

    Strange I did disable them it must have been the cache.

    The Autoptimize file is now out of the render blocking CSS resources in above the fold content which is great.

    What can I do about excluding the wp-content/themes/delicacy/style.css CSS file?

    There is also another CSS file coming up as a warning in render blocking CSS resources ?sccss=1&ver=4.8.1?

    Appreciate the help.

    Jamie

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    the answer to both questions is related actually;
    * ?sccss=1 is custom css you (or you webmaster) added using the simple custom css plugin. nowadays WordPress has a native custom CSS field in appearance -> customize -> additional CSS and that will AO to pick up your custom CSS as well.
    * the reason you had to exclude your theme’s main stylesheet was because of a margin getting lost. if you add (something like) this to your “additional CSS”, excluding the style.css will not be needed any more (some tweaking might apply);

    .entry-content p {
    	margin: 1em 0 !important;
    }

    hope this helps,
    frank

    That’s done wonders for mobile Frank! 🙂

    On desktop it is asking to optimize CSS delivery of /wp-content/cache/autoptimize/css/autoptimize_8552484b3d8eb2ba8de2aed93a8ea147.css

    Also, is it possible to do the same thing with Autoptimize to Remove render-blocking JavaScript?

    I am getting an error on desktop for /wp-content/cache/wpfc-minified/3913ad175436255dc53473a8004aba7a/1502816566index.js

    Thanks,
    Jamie

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    On desktop it is asking to optimize CSS delivery of /wp-content/cache/autoptimize/css/autoptimize_8552484b3d8eb2ba8de2aed93a8ea147.css

    then you’ll have to tweak your critical CSS (or generate it elsewhere) Jamie

    I am getting an error on desktop for /wp-content/cache/wpfc-minified/3913ad175436255dc53473a8004aba7a/1502816566index.js

    well, disabling WP Fastest Cache minification would be a start 🙂

    Ha, I’m starting to think it wasn’t worth purchasing WP Fastest Cache I keep disabling all the options!

    I tried the CSS generated from https://www.sitelocity.com/critical-path-css-generator and the optimize CSS delivery error message has gone 🙂

    Is there anything that can be done about external render blocking JS/CSS such as https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=2.1.3 and http://widget.alldishes.co.uk/blogcounter.js?blog_id=PuDKF&timestamp=1502866800 ?

    Thanks,
    Jamie

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I’m starting to think it wasn’t worth purchasing WP Fastest Cache I keep disabling all the options!

    It’s great at page caching though 😉

    Is there anything that can be done about external render blocking JS/CSS

    well, you could try with “async javascript” or try the “above the fold” plugin which can proxy remote resources 🙂

    I noticed Autoptimize also caches, is there a difference on how they both operate?

    I’m having a play with “above the fold” and having some success.

    Thanks for your ongoing help!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Well, AO optimizes and caches CSS/ JS and not the page (HTML), whereas WPFC as core functionality caches the pages (HTML) and can optionally optimize CSS/ JS.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Optimize CSS Code making content spacing wrong’ is closed to new replies.