Support » Plugin: Yoast SEO » Optimization fails

  • Resolved Christopher Mailänder

    (@ceem123)


    Hi there,

    After the latest plugin update, we were asked to optimize the database. As we have seen a huge drop in our rankings since then (must not be related), I wanted to start the optimization anew.

    For this: I installed the helper plugin, reset the tables and started the optimization.

    Unfortunately it fails after some minutes of running (indexation-1680.js:1 POST /wp-json/yoast/v1/link-indexing/posts 500)

    If it already ran for so long, is most of the optimization work already done then and only some minor thing missing or is this a major issue?

    Thank you in advance.

    Best regards,
    Christopher

    PS: Just checked the access log of the server and there are multiple 200 calls for the same URL. So at least something should be running through.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @ceem123

    We understand that the SEO data optimization is failing, and you’ve reset the indexables data using the Yoast Test Helper plugin, but that it still eventually fails to complete, with the JS error of (indexation-1680.js:1 POST /wp-json/yoast/v1/link-indexing/posts 500) appearing.

    Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    Would it be possible for you to reset the data using the Yoast Test Helper plugin, enable troubleshooting mode in the Health Check plugin, start with a default WP theme, and enable only Yoast SEO for WordPress, and see if you are able to complete the SEO data optimization process under SEO > Tools?

    Thread Starter Christopher Mailänder

    (@ceem123)

    Hi @mikes41720,

    Thank you very much for the quick reply and assistance.

    Found the issue: I hooked into woocommerce_product_add_to_cart_text via add_filter and apparently this broke the optimization on some pages.

    Best regards,
    Christopher

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.