Support » Fixing WordPress » Opmaak foutjes op home/categorieën

  • Resolved andrea1451986

    (@andrea1451986)


    Hi,

    Kunnen jullie me misschien helpen met een simpel stukje CSS dat ik kan invoeren/een plugin voor het volgende:

    Op de homepage van mijn website verdwijnt de opmaak van de artikelen/excerpts die er, wanneer geopend, wel is. Tabellen/kolommen met tekst in een heel artikel verdwijnen op de home, waardoor het een grote aaneen geregen tekstbrei wordt. Lelijk! Weet iemand hoe ik dit kan oplossen?

    Ook krijgen de categorieen boven mijn artikelen op de home een komma NA een spatie, tussen twee categorieen. Dus bijvoorbeeld: Content ,Poezie ,Blabla.
    Nog lelijker! Ik hoop op minstens 1 gouden tip voor deze monstrosity :).
    Duizendmaal dank!

    Groet, Andrea.

    • This topic was modified 1 year, 8 months ago by andrea1451986.
    • This topic was modified 1 year, 8 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator bcworkz

    (@bcworkz)

    The loss of formatting and tables is due to the auto-excerpt feature of WP. It must strip out HTML tags in order to accurately count words in the excerpt. To maintain formatting, you need to use the <!--more--> tag in content to manually indicate where to break the excerpt. Additionally, your theme’s template needs to call the_content() instead of the_excerpt().

    The code generating the category list is faulty. It is something your theme is doing. I recommend asking for assistance in your theme’s dedicated support forum. If you think you can patch your theme’s code yourself, that is OK, but you should create a child theme to contain your altered theme files.

    Thread Starter andrea1451986

    (@andrea1451986)

    Hi @bcworkz!

    Thanks so much for your reply. Sorry for my late response. Two questions: How do I insert the <!–more–> tag? Where do I do this, within the article itself? So for every article I would have to manually put that in, in the editor of the article itself? Trying to get it right.

    Also, what do you mean when you say: your theme’s template needs to call the_content() instead of the_excerpt() ? Where do I find this template? And can I change that myself, or does my theme somehow need to do it? In which doc would I find and change itw? Sorry, I am usually quick to understand, but with this I’d have to know exactly where to look.
    Wouldn’t it also already work if I manage to put the ‘more’ tag in every article and disable the excerpts in the CSS-customizer? Very curious.

    For the commas in the category list I will get in touch with my theme’s forum, thank you!

    Moderator bcworkz

    (@bcworkz)

    Read about the more tag here. There are a number of [possible implementations. The editor toolbar illustrated there is for the classic editor. The block editor also has a “more” block you can insert. Simply entering <!--more--> in editor code view accomplishes a similar function. What you need to avoid is the auto-excerpt function, the other options are usable.

    I prefer the manual insertion because I like to define where excerpts break. But going back to add the tags to existing posts could be an onerous task. Changing the_excerpt() to the_content() involves editing your theme’s files. Which file is somewhat theme dependent. The “Show Current Template” plugin can be helpful in determining the main template. The code you are seeking could be in an included template part, a separate file. You’d need to review the main template code for clues to which file comprises the template part.

    Disabling excerpts appears to be a theme function, so I don’t know what happens. I think it means you don’t have to edit theme files! Try it and see 🙂 Unless there’s a more tag, it’ll likely simply show full content. Insert a more tag into a post and see if that’s effective. This feature could save you a lot of theme investigation and editing!

    Thread Starter andrea1451986

    (@andrea1451986)

    Hi @bcworkz! Thank you so much for your help. I have disabled the excerpt-option in the customizer and did go in to every article I ever made to insert the more-tag :D. Fortunately I havent been writing much the past few years, but it was still a bit of work. Showing entire articles simply isnt an option, seeing as I have two columns and a sidebar, they would just be long pieces of text with no end. I might change it to one column.

    I asked about the commas in the category lists above posts on the theme support page, and was able to change something in the code, but then the space after a category was still double (like this: content , poetry). So outstanding question about how to get rid of this extra spacing as it is butt ugly pardon my French.
    Thanks for now!

    Thread Starter andrea1451986

    (@andrea1451986)

    Oh, you cant see double spacing haha! Well it is double.

    Moderator bcworkz

    (@bcworkz)

    Two spaces is a lot better than a misplaced comma, but I understand your continued unhappiness with the situation. This being a theme issue, there isn’t much I can do to help. Since you had found where to remove the comma, it seems like the extra space should be coming from closely related code. Perhaps if you posted what appears to be related code before and after where you edited out the comma, I could spot the cause. I’m not very hopeful of success, but it’s worth a try.

    Thread Starter andrea1451986

    (@andrea1451986)

    Hi @bcworkz, thanks for your help, I had already set out the question in the theme’s forum and he was able to help! It was something I could add in the extra css space. Whoop. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Opmaak foutjes op home/categorieën’ is closed to new replies.