Support » Plugin: WooCommerce Redsys Gateway Light » Operaciones denegadas con Bizum (9966 – CJ00300). Pero aprobadas con tarjeta.

  • Buenos días.

    A ver si me podéis ayudar con este error, pues he intentado buscar alguna solución pero no la he encontrado, por desgracia. Lleva pasando bastante tiempo.

    El pago funciona correctamente si se realiza con tarjeta de crédito/débito, pero al intentar realizarla con Bizum, es imposible.

    En el terminal de Redsys la operación sale siempre como Denegada 9966 – CJ00300. He visto en la ayuda de Redsys que 9966 es que Bizum devuelve KO.

    En los detalles de operación:
    – Resultado operación Denegada
    – Código Respuesta 00300

    En los detalles de notificación 1:
    Fecha y hora 27/06/2022 08:52:37
    Tipo notificación HTTP
    Modo de comunicación Síncrona
    Resultado operación 9966
    Cod. respuesta servidorCorrecto (200)
    Destino notificación http://www.***.com/?wc-api=WC_Gateway_bizumredsys

    En los detalles de notificación 2:
    Fecha y hora27/06/2022 08:52:37
    Tipo notificación E-Mail
    Modo de comunicación Asíncrona
    Resultado operación 9966
    Cod. respuesta servidorCorrecto (OK)

    He mirado el LOG de WooCommerce y aparecen las siguientes anotaciones:
    [27-Jun-2022 06:52:37 UTC] PHP Notice: Undefined index: Ds_Merchant_Identifier in /home/***/www/wp-content/plugins/woo-redsys-gateway-light/includes/apiRedsys7.php on line 35
    [27-Jun-2022 06:52:37 UTC] PHP Notice: Undefined index: Ds_Card_Brand in /home/***/www/wp-content/plugins/woo-redsys-gateway-light/includes/apiRedsys7.php on line 35
    [27-Jun-2022 06:52:37 UTC] PHP Notice: Undefined index: Ds_Card_Type in /home/***/www/wp-content/plugins/woo-redsys-gateway-light/includes/apiRedsys7.php on line 35
    [27-Jun-2022 06:52:37 UTC] PHP Notice: Undefined index: Ds_ErrorCode in /home/***/www/wp-content/plugins/woo-redsys-gateway-light/includes/apiRedsys7.php on line 35
    [27-Jun-2022 06:52:37 UTC] PHP Notice: Undefined index: Ds_PayMethod in /home/***/www/wp-content/plugins/woo-redsys-gateway-light/includes/apiRedsys7.php on line 35

    Utilizo Let’s Encrypt y Simple SSL. He puesto el código en el HTACCESS. He probado con y sin compatibilidad SNI.

    Creo que todas las configuraciones son correctas, pero no doy con la clave. ¿Os ha pasado algo parecido?

    Muchas gracias por la atención.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jose Conti

    (@jconti)

    Hola,

    Como bien dices, es una denegación por parte de Bizum. ¿Son pruebas en el terminal real?

    Thread Starter anxosanchezgarcia

    (@anxosanchezgarcia)

    Sí, correcto. En terminal real. La web está online y lleva con Redsys bastante tiempo. De hecho, al principio bizum también funcionaba pero hace meses que dejó de hacerlo.

    Con tarjetas va perfecto, ningún fallo.

    ¿Será un problema del banco? (Ellos dicen que no hehehe).

    ¡Muchas gracias por la respuesta, José!

    Plugin Author Jose Conti

    (@jconti)

    Yo hablaría con el correo de soporte del banco, @anxosanchezgarcia.

    Puede que algo se haya desconfigurado en el terminal/Bizum. Hay veces que sucede. Lo que igual te dicen que instales su plugin porque no dan soporte a plugins de terceros, que deberías tener el mismo problema.

    Instala el plugin suyo, si es que no lo has hecho ya en algún momento, y prueba una transación a ver qué sucede, con el mismo producto y precio. Me sorprendería que no tuvieras el mismo error.

    Pregunta tonta, La cuenta de Bizum que utilizáis para los pagos (el número de teléfono), funciona de forma correcta ¿no?

    Saludos

    Thread Starter anxosanchezgarcia

    (@anxosanchezgarcia)

    Sí, ha pasado con varios números. En este caso, estoy probando con el mío que para otras operaciones no ha dado errores.

    No he probado con otro plugin. Lo haré y hablaremos de nuevo con el banco. A ver si hay suerte. Ya te comento.

    Gracias!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.