Support » Plugin: Events Manager - OpenStreetMaps » OpenStreetMaps are responsive in this Plugin?

  • Resolved mustermann

    (@mustermann)


    Hi Patrick,

    Iยดm lookking on my iPhone and iPad and I can see the OpenStreetMap are not responsive.

    The seeing OpenStreetMap looks on a destop fine, but on iPhone and iPad it is divides in some parts and is floating over the site.

    Do you have an idea to fix this problem?

    Thank you for help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Hi ๐Ÿ™‚
    It looks like it is something in your map configuration and/or css. Even on a mobile it should look good. See https://www.guidepatrick.nl/agenda/city-tour-2019-01-04/ That’s where I use it myself. ๐Ÿ™‚

    Could you please provide the code you are using?

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    It seems AO is still altering the code…
    This is what your source page says:
    <div id="em-osm-map-container"> <script src="https://oldtimer-veranstaltung.de/kalender/wp-content/cache/autoptimize/js/autoptimize_single_1b21ef8c41ccb6eb33c8b000c9517ee9.js"></script> <script src="https://oldtimer-veranstaltung.de/kalender/wp-content/cache/autoptimize/js/autoptimize_single_d92a6a6716fd610aa42402dc6d4eda47.js"></script> <div id="em-osm-map" style="width: 400px; height: 340px; position: relative;" class="leaflet-container leaflet-touch leaflet-fade-anim leaflet-grab leaflet-touch-drag leaflet-touch-zoom" tabindex="0">

    If I add the ?ao_noptimize=1 to the url again, it works ๐Ÿ™‚

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Additionally,
    You might want to add a media query to your css for maps in mobile mode.

    Something like:

    @media screen and (max-width:500px) {
    #em-osm-map-container {max-width: 100% !important;}
    }

    Hi Patrick,
    thank you for your very fast feedback. Should I put the code from your last feedback in style.css from my child theme?

    Do you think about an other file?

    Regards

    Ah, AO will minify un-minified JS even if excluded from aggregation (based on filename not ending in (-|.)min.js , you can stop that with this code snippet;

    
    add_filter('autoptimize_filter_js_minify_excluded','__return_false');

    Patrick; maybe consider minifying your files (and naming them as such)? Groeten uit Belgiรซ overigens ๐Ÿ™‚

    hope this helps,
    frank

    Hi Optimize Matters,
    Hi Patrick,

    I have disabled plugin autoptimize. I think a script or something else I should exclude from autoptimize.

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Great advise, Frank.
    There is an issue with minifying though ๐Ÿ™

    Anyway to contact you by email, Frank?

    Hi,

    now i have enabled autoptimize and the problem is on the screen.

    Which “thing” I should exclude from autoptimize?

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Hang on! I will make an update of the plugin. ๐Ÿ˜€

    Hi Frank,
    Hi Patrick,
    it is the best support I have ever seen.

    Thanks for help both.

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Version 1.7.3 should be ready for download ๐Ÿ™‚

    Hi Patrick,

    I have updated to Version 1.7.3 and not disabled autoptimize. The result is the same on desktop is it ok, smaller desktop OpenstreetMap is broken and the same on iPhone and iPad.

    Before I have cleard cache on WP Cache and the browsers.

    Hi Patrick,
    I just updated with version 1.7.3, but I still have an error when creating a new event, with the following messages:

    Warning: include(partials/location-select.php): failed to open stream: No such file or directory in /homepages/18/d761824240/htdocs/clickandbuilds/AnnonayRseauInfoSant/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 143

    Warning: include(): Failed opening ‘partials/location-select.php’ for inclusion (include_path=’.:/usr/lib/php7.0′) in /homepages/18/d761824240/htdocs/clickandbuilds/AnnonayRseauInfoSant/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 143

    With thanks.
    Jacques

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Hi Jacques,
    You are referring to something else than this topic. Please create new one.

    Hi Patrick,

    in the moment I have disabled autoptimize and it works fine. I will be back to test after 3 h pm.

    Thanks for help

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘OpenStreetMaps are responsive in this Plugin?’ is closed to new replies.