WordPress.org

Forums

[resolved] opening *.php error (9 posts)

  1. shanta
    Member
    Posted 9 years ago #

    My problem began as a error similar to that described in thread #66321: each time I publish from Write Post, Firefox 1.5 tries to open post.php, but most times publishes the post. In IE 6, 'Page cannot be displayed' displays when I try to publish, but post is still published. Inconvenient, but I can live with it.

    Now this happens when I try to log in, change themes, or try to change options, my browser tries to open the corresponding *.php. Now sometimes the post does not publish, the theme can't be changed, and I'm not able to log in.

    I did deactivate all my plugins; this had no effect on the problem. (It's an intermittent problem, so its hard to be sure)

    I have no idea where to start trouble-shooting this.
    Advice would be greatly appreciated. I am new to WordPress, so please explain gently if you can.

    PHP 5.0.4
    Wordpress 2.02
    http://shantarohse.com/

  2. shanta
    Member
    Posted 9 years ago #

    I'd really appreciate a suggestion for this. At this point, even a shot in the dark is welcome.

  3. Samuel B
    moderator
    Posted 9 years ago #

    OK - shot in the dark.
    Turn off wysiwyg editor and update permalinks.
    If that doesn't work, upload a fresh wp-admin.php.

  4. shanta
    Member
    Posted 9 years ago #

    I'm afraid it didn't work, but thanks for trying samboll.

  5. shanta
    Member
    Posted 9 years ago #

    Ok let's try something different. Is anyone else having similar problems to mine? At least I won't feel so all alone :( Maybe I'm forgetting some important detail that would help these wonderful support gurus.

    I did find these similar posts; but they are too old for me to feel confident about following their advice:
    http://wordpress.org/support/topic/24423?replies=8
    http://wordpress.org/support/topic/26867?replies=4
    http://wordpress.org/support/topic/59786?replies=3

    An error with post.php seems to be common. But my problem is 1) all *.php, and mostly with login.php and 2) intermitent:
    http://wordpress.org/support/topic/61241?replies=2
    http://wordpress.org/support/topic/58296?replies=1

    Should I be asking this in a different support forum like PHP?

  6. Chris_K
    Member
    Posted 9 years ago #

    Do you have control over your php configuration? If I were to make my own wild guess, I'd say you need to configure PHP max memory to be more than the default 8MB.

    I had a similar situation that was resolved by increasing memory to 20MB.

  7. shanta
    Member
    Posted 9 years ago #

    Bingo. That fixed it. Thanks for sharing that priceless suggestion, HandySolo.

  8. shanta
    Member
    Posted 9 years ago #

    HandySolo - as an aside, why did this work? What problem does it address? What would make demands on PHP memory be higher?

  9. IIIIIIIV
    Member
    Posted 9 years ago #

    From the php.ini guide...

    memory_limit integer

    This sets the maximum amount of memory in bytes that a script is allowed to allocate. This helps prevent poorly written scripts for eating up all available memory on a server. In order to use this directive you must have enabled it at compile time. So, your configure line would have included: --enable-memory-limit. Note that you have to set it to -1 if you don't want any limit for your memory.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags