Support » Plugins » OpenID URL error

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve been having the same problem with my setup.

    WordPress 2.3.6 on Linux and MacOSX
    url: cxcheng.myopenid.com which is valid

    Hey guys, I’ve been having the same problem, and found a possible solution over at a Google discussion forum. Here’s the answer (which I haven’t tried yet):

    “The wp-openid plugin doesn’t actually create or setup your OpenID URL,
    it only allows OTHER people with OpenIDs to login to YOUR blog. I can
    see how this would be confusing, and it will either be improved later
    on (by including the wp-yadis/delegation functionality) or shipping an
    OpenID provider with the plugin.

    For now, you’ll need to install this plugin to setup your blog as your OpenID:

    http://wordpress.org/extend/plugins/yadis/

    you also could use Stephen Paul Weber’s XRDS plugin:

    http://singpolyma.net/plugins/xrds/

    Both should achieve the same thing for you.

    Chris”

    Hopefully this will work

    Although setting up my blog AS my OpenID _might_ solve the problem I already have a 3rd Party OpenID. I’ve been able to login just fine with the 3rd party OpenID URL as well as _occasionally_ with my blog as a delegate to it but now I’m getting this error more often than not. Other services are validating my url as a delegate just fine…. any ideas?

    I’ve updated the php-openid library and released v2.1.6. I tried using http://www.richardsilverstein.com/ on my site, and discovery worked fine. of course I couldn’t authenticate, but it at least discovered the openid server alright and sent me over to MyOpenID.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘OpenID URL error’ is closed to new replies.